aboutsummaryrefslogtreecommitdiff
path: root/security/acmetool
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-06 05:28:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-06 05:28:54 +0000
commita0f694eeec057cfa681826b1e15fd422fff8df17 (patch)
treefa4af168c91a5a185eb0d22cdbc324ead3ad4479 /security/acmetool
parent9e41abde7ff2a28ab5904a2a97ce6a99906c4f2e (diff)
security/acmetool: Update to 0.0.67
Port changes: * Changed to DISTVERSION * Updated revisions in GH_TUPLE * Silenced build commands * Use MAKE_ENV PR: 226379 Submitted by: samm@os2.kiev.ua Approved by: tcberner (mentor, implicit)
Notes
Notes: svn path=/head/; revision=463689
Diffstat (limited to 'security/acmetool')
-rw-r--r--security/acmetool/Makefile30
-rw-r--r--security/acmetool/distinfo50
2 files changed, 40 insertions, 40 deletions
diff --git a/security/acmetool/Makefile b/security/acmetool/Makefile
index eecf11a821a9..28ff24c9fa6c 100644
--- a/security/acmetool/Makefile
+++ b/security/acmetool/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= acmetool
-PORTVERSION= 0.0.62
DISTVERSIONPREFIX= v
+DISTVERSION= 0.0.67
CATEGORIES= security
MAINTAINER= samm@os2.kiev.ua
@@ -18,44 +18,44 @@ GH_PROJECT= acme
GH_SUBDIR= src/github.com/hlandau/acme
GH_TUPLE= alecthomas:template:a0175ee:template/src/github.com/alecthomas/template \
alecthomas:units:2efee85:units/src/github.com/alecthomas/units \
- coreos:go-systemd:c966a8a:go_systemd/src/github.com/coreos/go-systemd \
- hlandau:acme:2c2e661:acme/src/github.com/hlandau/acme \
+ coreos:go-systemd:749ef98:go_systemd/src/github.com/coreos/go-systemd \
+ hlandau:acme:221ea15:acme/src/github.com/hlandau/acme \
hlandau:buildinfo:337a29b:buildinfo/src/github.com/hlandau/buildinfo \
hlandau:dexlogconfig:244f29b:dexlogconfig/src/github.com/hlandau/dexlogconfig \
hlandau:goutils:0cdb66a:goutils/src/github.com/hlandau/goutils \
hlandau:xlog:197ef79:xlog/src/github.com/hlandau/xlog \
jmhodges:clock:880ee4c:clock/src/github.com/jmhodges/clock \
mattn:go-isatty:6ca4dbf:go_isatty/src/github.com/mattn/go-isatty \
- mattn:go-runewidth:97311d9:go_runewidth/src/github.com/mattn/go-runewidth \
+ mattn:go-runewidth:a9d6d1e:go_runewidth/src/github.com/mattn/go-runewidth \
mitchellh:go-wordwrap:ad45545:go_wordwrap/src/github.com/mitchellh/go-wordwrap \
ogier:pflag:45c278a:pflag/src/github.com/ogier/pflag \
- peterhellberg:link:3eea38c:link/src/github.com/peterhellberg/link \
- satori:go.uuid:5bf94b6:go_uuid/src/github.com/satori/go.uuid \
+ peterhellberg:link:6d32b8d:link/src/github.com/peterhellberg/link \
+ satori:go.uuid:36e9d2e:go_uuid/src/github.com/satori/go.uuid \
shiena:ansicolor:a422bbe:ansicolor/src/github.com/shiena/ansicolor \
- golang:crypto:d585fd2:crypto/src/golang.org/x/crypto \
- golang:net:d866cfc:net/src/golang.org/x/net \
- golang:sys:8380141:sys/src/golang.org/x/sys \
- golang:text:e19ae14:text/src/golang.org/x/text \
+ golang:crypto:91a49db:crypto/src/golang.org/x/crypto \
+ golang:net:22ae77b:net/src/golang.org/x/net \
+ golang:sys:dd2ff4a:sys/src/golang.org/x/sys \
+ golang:text:b7ef84a:text/src/golang.org/x/text \
alecthomas:kingpin:947dcec:kingpin/src/gopkg.in/alecthomas/kingpin.v2 \
- cheggaaa:pb:18d384d:pb/src/gopkg.in/cheggaaa/pb.v1 \
+ cheggaaa:pb:72b9643:pb/src/gopkg.in/cheggaaa/pb.v1 \
hlandau:configurable:4149686:configurable/src/gopkg.in/hlandau/configurable.v1 \
hlandau:easyconfig:7589cb9:easyconfig/src/gopkg.in/hlandau/easyconfig.v1 \
hlandau:service:b64b346:service/src/gopkg.in/hlandau/service.v2 \
hlandau:svcutils:c25dac4:svcutils/src/gopkg.in/hlandau/svcutils.v1 \
square:go-jose:aa2e30f:go_jose/src/gopkg.in/square/go-jose.v1 \
tylerb:graceful:4654dfb:graceful/src/gopkg.in/tylerb/graceful.v1 \
- go-yaml:yaml:287cf08:go_yaml/src/gopkg.in/yaml.v2
+ go-yaml:yaml:7f97868:go_yaml/src/gopkg.in/yaml.v2
do-build:
- cd ${WRKSRC}/src/github.com/hlandau/acme ; \
- ${SETENV} GOPATH=${WRKSRC} \
+ @cd ${WRKSRC}/src/github.com/hlandau/acme && \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} \
go build -o ${WRKSRC}/bin/${PORTNAME} -ldflags "\
-X github.com/hlandau/acme/hooks.DefaultPath=${PREFIX}/libexec/acme/hooks \
-X github.com/hlandau/acme/storage.RecommendedPath=/var/db/acme \
-X github.com/hlandau/buildinfo.BuildInfo=${PORTNAME}-v${PORTVERSION}-freebsd-ports \
"\
github.com/hlandau/acme/cmd/acmetool
- ${WRKSRC}/bin/${PORTNAME} --help-man > ${WRKSRC}/${PORTNAME}.8
+ @${WRKSRC}/bin/${PORTNAME} --help-man > ${WRKSRC}/${PORTNAME}.8
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
diff --git a/security/acmetool/distinfo b/security/acmetool/distinfo
index e2099365211d..0b44513004b4 100644
--- a/security/acmetool/distinfo
+++ b/security/acmetool/distinfo
@@ -1,14 +1,14 @@
-TIMESTAMP = 1514418588
-SHA256 (hlandau-acme-v0.0.62_GH0.tar.gz) = ceaab0bc974846a26bce79e918ab79080013f6eed05dc981347c48eefde6d4f5
-SIZE (hlandau-acme-v0.0.62_GH0.tar.gz) = 132853
+TIMESTAMP = 1520313517
+SHA256 (hlandau-acme-v0.0.67_GH0.tar.gz) = 01f78340006539c62bb86250433d2f819ab529ccd9a0aa74e140ff0fee839073
+SIZE (hlandau-acme-v0.0.67_GH0.tar.gz) = 133424
SHA256 (alecthomas-template-a0175ee_GH0.tar.gz) = 18330bd4bf73af704ec42953b6106e256b58314c7931bcd5aedf41b470ee3dc8
SIZE (alecthomas-template-a0175ee_GH0.tar.gz) = 55261
SHA256 (alecthomas-units-2efee85_GH0.tar.gz) = 8e84e0468232e23459212cf84e38164a43b1c8b7a2788a44c9446c01b684c39d
SIZE (alecthomas-units-2efee85_GH0.tar.gz) = 3445
-SHA256 (coreos-go-systemd-c966a8a_GH0.tar.gz) = 161cf9d7677bb05a54cf73c509d2563878c734734d785b5a3bee6a888fcb6c17
-SIZE (coreos-go-systemd-c966a8a_GH0.tar.gz) = 55430
-SHA256 (hlandau-acme-2c2e661_GH0.tar.gz) = e5c0ee4a1d21de576ccc13e29582a3e0e01fc264f04e5b8ef1dd4e89e180c4f8
-SIZE (hlandau-acme-2c2e661_GH0.tar.gz) = 132850
+SHA256 (coreos-go-systemd-749ef98_GH0.tar.gz) = 02b110e1c89a321a4deb9c9a4d7c7130c868e0881ab68d491f0b818d555f73c6
+SIZE (coreos-go-systemd-749ef98_GH0.tar.gz) = 59316
+SHA256 (hlandau-acme-221ea15_GH0.tar.gz) = 8fbc3f3d274ffa47b5b7020d8d97aa975ef4a67e6b0792e9d682509f58529527
+SIZE (hlandau-acme-221ea15_GH0.tar.gz) = 133430
SHA256 (hlandau-buildinfo-337a29b_GH0.tar.gz) = b2678ee8f07d0dcfb96ddc47fc7d5c3ee6896eb4951dc35a22b56b647ee34789
SIZE (hlandau-buildinfo-337a29b_GH0.tar.gz) = 2601
SHA256 (hlandau-dexlogconfig-244f29b_GH0.tar.gz) = 55ce7d2b431a55c3827c5df975b4d8194e61ae5b5a2c273385355ec351cde4c3
@@ -21,30 +21,30 @@ SHA256 (jmhodges-clock-880ee4c_GH0.tar.gz) = 1f80d14a42f1f30341a7040460cada7f555
SIZE (jmhodges-clock-880ee4c_GH0.tar.gz) = 5759
SHA256 (mattn-go-isatty-6ca4dbf_GH0.tar.gz) = 4ae0da6d6d3f5bf7b86570e38a057331f7b2830bd5d0c1fc670758672f7521cf
SIZE (mattn-go-isatty-6ca4dbf_GH0.tar.gz) = 3383
-SHA256 (mattn-go-runewidth-97311d9_GH0.tar.gz) = 8330497728f75464111ee7145fc97cfa588cb0d6561b3af5447aa05d489bca85
-SIZE (mattn-go-runewidth-97311d9_GH0.tar.gz) = 22384
+SHA256 (mattn-go-runewidth-a9d6d1e_GH0.tar.gz) = b6192077762ad9e35a5e57283e7b5bb3da5b726740ef1f1278c1f599ba52d1c7
+SIZE (mattn-go-runewidth-a9d6d1e_GH0.tar.gz) = 22855
SHA256 (mitchellh-go-wordwrap-ad45545_GH0.tar.gz) = f9ddaffa2229c278a6b61ba3f73b6d08695ef55e1cfea7d139e53728ea4d13ec
SIZE (mitchellh-go-wordwrap-ad45545_GH0.tar.gz) = 2737
SHA256 (ogier-pflag-45c278a_GH0.tar.gz) = 4069c7cdac6c83cbf896a2a68c23846dcb41c8498c3e20b00cf8b35de35ea82b
SIZE (ogier-pflag-45c278a_GH0.tar.gz) = 15814
-SHA256 (peterhellberg-link-3eea38c_GH0.tar.gz) = 5a4c027ca262f4a782f26f4c53b516779ced84729d4566cb8c743f1cbf7f3c91
-SIZE (peterhellberg-link-3eea38c_GH0.tar.gz) = 4200
-SHA256 (satori-go.uuid-5bf94b6_GH0.tar.gz) = eb26d69da0a36d9318183dd4a15b162cf8d6e4493f6c12ae635ba0a072e06da1
-SIZE (satori-go.uuid-5bf94b6_GH0.tar.gz) = 7607
+SHA256 (peterhellberg-link-6d32b8d_GH0.tar.gz) = 6abe4ff7a5f23e6c6b8f54ef0e57dbcff8e7e987c6581a2b63bebbc4701511ab
+SIZE (peterhellberg-link-6d32b8d_GH0.tar.gz) = 4229
+SHA256 (satori-go.uuid-36e9d2e_GH0.tar.gz) = aa54b317ac4122e7a4db33f84bac64fa9079637f4fd0517206c06d1aa1341b2d
+SIZE (satori-go.uuid-36e9d2e_GH0.tar.gz) = 8738
SHA256 (shiena-ansicolor-a422bbe_GH0.tar.gz) = 0e8994e5d633d56c111fa0b985092b6f45cfa04efb2b70cb34eeb430eafa7f79
SIZE (shiena-ansicolor-a422bbe_GH0.tar.gz) = 7320
-SHA256 (golang-crypto-d585fd2_GH0.tar.gz) = d8680943f1dd9203d156f6491b4106939becf4f4ee4f616b79e573ed9096f650
-SIZE (golang-crypto-d585fd2_GH0.tar.gz) = 1440857
-SHA256 (golang-net-d866cfc_GH0.tar.gz) = 9555e426a10cb8d94ad3b0ee5d6a0ed4c38211055da98af92d085929b5559f33
-SIZE (golang-net-d866cfc_GH0.tar.gz) = 929432
-SHA256 (golang-sys-8380141_GH0.tar.gz) = 416fc561da9ec7048f63c212ed3805c207d6ce253d609d698ea6e32090a1e6ca
-SIZE (golang-sys-8380141_GH0.tar.gz) = 788176
-SHA256 (golang-text-e19ae14_GH0.tar.gz) = 1b1c7609e3a77300547de282a6693b1d779bbfd051c3d98ae3af73c7a9a4958d
-SIZE (golang-text-e19ae14_GH0.tar.gz) = 6113358
+SHA256 (golang-crypto-91a49db_GH0.tar.gz) = 1039827935c26b4f430405e3da870c324ebc231c9f4e5f7b2622fac1a1fc9246
+SIZE (golang-crypto-91a49db_GH0.tar.gz) = 1451212
+SHA256 (golang-net-22ae77b_GH0.tar.gz) = a5788e4383e8131e0b2ac2397194fc3b2e3f9d26df496ccd615a0dc7ff81c493
+SIZE (golang-net-22ae77b_GH0.tar.gz) = 937441
+SHA256 (golang-sys-dd2ff4a_GH0.tar.gz) = 74b19ce75abab70e09231c497badbf7d87b2d9941504ec68721dcffa8faa6de4
+SIZE (golang-sys-dd2ff4a_GH0.tar.gz) = 799474
+SHA256 (golang-text-b7ef84a_GH0.tar.gz) = 4245d79bc0b0dfb7815ece3f32a18c288e8f4190f5c72db41520987c7c315f29
+SIZE (golang-text-b7ef84a_GH0.tar.gz) = 6572198
SHA256 (alecthomas-kingpin-947dcec_GH0.tar.gz) = 3de3402ae26695879bc209abd57a6108e3f1a172a874d26c2578fbb29d4668cb
SIZE (alecthomas-kingpin-947dcec_GH0.tar.gz) = 44387
-SHA256 (cheggaaa-pb-18d384d_GH0.tar.gz) = 2a216053b524cdc7024d6d2d85e9ff815662492e76bcf06b69420d8a6465d2a6
-SIZE (cheggaaa-pb-18d384d_GH0.tar.gz) = 11376
+SHA256 (cheggaaa-pb-72b9643_GH0.tar.gz) = ffc792c0a8e86aeddab5d4d1d07d0284958f8ba08a827587d0591704c3a29757
+SIZE (cheggaaa-pb-72b9643_GH0.tar.gz) = 11521
SHA256 (hlandau-configurable-4149686_GH0.tar.gz) = 79ee1e53ebead6d94b0eac2617c963a4e55edd744ac9c528dfb3a8acf132f82f
SIZE (hlandau-configurable-4149686_GH0.tar.gz) = 2692
SHA256 (hlandau-easyconfig-7589cb9_GH0.tar.gz) = b5e9bdd121d99bb33a67bdf398e69ca1233fac7619da11120523c962c6f5a06a
@@ -57,5 +57,5 @@ SHA256 (square-go-jose-aa2e30f_GH0.tar.gz) = 9af3ff28889e88ef9daa42e54f37e2cacff
SIZE (square-go-jose-aa2e30f_GH0.tar.gz) = 260572
SHA256 (tylerb-graceful-4654dfb_GH0.tar.gz) = 1c3320d71c47adb5ffcc10f0e5c641e0c9ccdb7e03e9d5f2f42498d2b809f217
SIZE (tylerb-graceful-4654dfb_GH0.tar.gz) = 15029
-SHA256 (go-yaml-yaml-287cf08_GH0.tar.gz) = aee4e721ad32af6a51b820a3eef69bcab168b4ac4425a582b3497ac301c850dc
-SIZE (go-yaml-yaml-287cf08_GH0.tar.gz) = 64713
+SHA256 (go-yaml-yaml-7f97868_GH0.tar.gz) = b0215657c82db81fa1e10f73fb1df3db12715ec68a14ab555e7f40d1d174132d
+SIZE (go-yaml-yaml-7f97868_GH0.tar.gz) = 69163