aboutsummaryrefslogtreecommitdiff
path: root/security/afterglow/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-09-08 05:49:35 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-09-08 05:49:35 +0000
commiteb818ba0a8665f15b1f5b3d0e82a3f6cc67f61a6 (patch)
tree9684f734c282b3183e6c03fe947d10ab88ed22f3 /security/afterglow/Makefile
parente0f850f496bb3ee288cb8a0db8ed6c77c41eec81 (diff)
Notes
Diffstat (limited to 'security/afterglow/Makefile')
-rw-r--r--security/afterglow/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/security/afterglow/Makefile b/security/afterglow/Makefile
new file mode 100644
index 000000000000..a3a15c8f6c3f
--- /dev/null
+++ b/security/afterglow/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: afterglow
+# Date created: 1 Aug 2007
+# Whom: pauls
+#
+# $FreeBSD$
+#
+
+PORTNAME= afterglow
+PORTVERSION= 1.5
+CATEGORIES= security graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= afterglow
+
+MAINTAINER= pauls@utdallas.edu
+COMMENT= A collection of graph-generating scripts
+
+RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DB_SCRIPTS= attackchains.pl deltacalc2.pl deltacalc.pl iptolong.pl \
+ snortalert.pl snortdirection.pl snortservice.pl subquery.pl \
+ tcpdump2sql.pl
+GRAPH_SCRIPTS= afterglow-lgl.pl afterglow-lgl2.pl afterglow-walrus.pl afterglow.pl
+PARSERS= pf2csv.pl sendmail_parser.pl tcpdump2csv.pl
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${MKDIR} ${DATADIR}/data
+ ${MKDIR} ${DATADIR}/database
+ ${MKDIR} ${DATADIR}/graph
+ ${MKDIR} ${DATADIR}/parsers
+ (cd ${WRKSRC}/data/ && ${COPYTREE_SHARE} \* ${DATADIR}/data "! -name generate.pl")
+ (cd ${WRKSRC}/src/perl/database/ && ${COPYTREE_SHARE} \* ${DATADIR}/database "! -name *\.pl")
+ (cd ${WRKSRC}/src/perl/graph/ && ${COPYTREE_SHARE} \* ${DATADIR}/graph "! -name *\.pl")
+ (cd ${WRKSRC}/src/perl/parsers/ && ${COPYTREE_SHARE} \* ${DATADIR}/parsers "! -name *\.pl")
+ ${INSTALL_SCRIPT} ${WRKSRC}/data/generate.pl ${DATADIR}/data/
+.for f in ${DB_SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/database/${f} ${DATADIR}/database/${f}
+.endfor
+.for f in ${GRAPH_SCRIPTS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/graph/${f} ${DATADIR}/graph/${f}
+.endfor
+.for f in ${PARSERS}
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/perl/parsers/${f} ${DATADIR}/parsers/${f}
+.endfor
+
+.include <bsd.port.mk>