aboutsummaryrefslogtreecommitdiff
path: root/security/amap/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-06-30 02:10:18 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-06-30 02:10:18 +0000
commitbaa6cf5915e442ce0d9343790a75cbbff490215c (patch)
treefba8d1d540a75ae08c3fd062e2386138886ac5e1 /security/amap/Makefile
parent4d1f518f7ce1b881cdf6b20e16fe0be3060dd899 (diff)
Notes
Diffstat (limited to 'security/amap/Makefile')
-rw-r--r--security/amap/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/security/amap/Makefile b/security/amap/Makefile
index b8fd09b97598..f517cc9f2790 100644
--- a/security/amap/Makefile
+++ b/security/amap/Makefile
@@ -6,17 +6,16 @@
#
PORTNAME= amap
-PORTVERSION= 1.2.1
+PORTVERSION= 2.7
CATEGORIES= security
MASTER_SITES= http://www.thc.org/releases/
-EXTRACT_SUFX= .tgz
MAINTAINER= Yonatan@xpert.com
COMMENT= Application mapper
HAS_CONFIGURE= yes
USE_REINPLACE= yes
-ALL_TARGET= all
+
MAN1= amap.1
post-patch:
@@ -24,9 +23,17 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/amap ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/amapcrap ${PREFIX}/bin/
${MKDIR} ${PREFIX}/share/amap
${INSTALL_DATA} ${WRKSRC}/appdefs.resp ${PREFIX}/share/amap/
+ ${INSTALL_DATA} ${WRKSRC}/appdefs.rpc ${PREFIX}/share/amap/
${INSTALL_DATA} ${WRKSRC}/appdefs.trig ${PREFIX}/share/amap/
${INSTALL_MAN} ${WRKSRC}/amap.1 ${MANPREFIX}/man/man1/
+. if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for i in README BUGS TODO CHANGES LICENSE
+ ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
+. endfor
+. endif
.include <bsd.port.mk>