aboutsummaryrefslogtreecommitdiff
path: root/security/amavis-stats
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-10 14:58:27 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-10 14:58:27 +0000
commitad7bd3136e45daab63c7ac1ffaedf2b9813158ed (patch)
treefe644c9f67063323819624d9d73a29b21f8dad8f /security/amavis-stats
parentb1cd6a3e1f29f2cf940d3b761be70c547d7686dc (diff)
downloadports-ad7bd3136e45daab63c7ac1ffaedf2b9813158ed.tar.gz
ports-ad7bd3136e45daab63c7ac1ffaedf2b9813158ed.zip
Notes
Diffstat (limited to 'security/amavis-stats')
-rw-r--r--security/amavis-stats/Makefile1
-rw-r--r--security/amavis-stats/files/patch-amavis-stats79
2 files changed, 77 insertions, 3 deletions
diff --git a/security/amavis-stats/Makefile b/security/amavis-stats/Makefile
index f27ce9ef7998..dd64a2eb6520 100644
--- a/security/amavis-stats/Makefile
+++ b/security/amavis-stats/Makefile
@@ -7,6 +7,7 @@
PORTNAME= amavis-stats
PORTVERSION= 0.1.12
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://rekudos.net/download/
diff --git a/security/amavis-stats/files/patch-amavis-stats b/security/amavis-stats/files/patch-amavis-stats
index 57bd5436bdaa..486550ad55ff 100644
--- a/security/amavis-stats/files/patch-amavis-stats
+++ b/security/amavis-stats/files/patch-amavis-stats
@@ -1,6 +1,20 @@
---- amavis-stats.orig Sat Mar 27 17:25:27 2004
-+++ amavis-stats Sun Jun 6 01:15:27 2004
-@@ -83,8 +83,8 @@
+--- amavis-stats.orig Sat Mar 27 23:25:27 2004
++++ amavis-stats Mon Jul 10 22:55:19 2006
+@@ -1,4 +1,4 @@
+-#! /usr/bin/perl
++#!/usr/bin/perl -w
+ #
+ # amavis-stats -- generate rrds from amavis log output
+ #
+@@ -28,6 +28,7 @@
+ # ########################################################################
+ use strict;
+ use warnings;
++use diagnostics;
+ use Getopt::Std;
+ use Time::localtime;
+ use Time::Local;
+@@ -83,8 +84,8 @@
$version = "0.1.12"; # this value is auto-updated by packing system
$pkg = "amavis-stats";
$locale = "C";
@@ -11,3 +25,62 @@
$statefile = "$statedir/$pkg.state"; # last read position of the logfile
$namesfile = "$statedir/$pkg.names"; # stores the virus name to id mappings
$countfile = "$statedir/$pkg.count"; # per virus totals
+@@ -212,7 +213,7 @@
+ sub semlock {
+ open (LOCKF, ">$lockfile") or do_exit(1, "Could not open $lockfile: $!");
+ unless (flock(LOCKF, LOCK_EX | LOCK_NB)) {
+- err("warning: Could not lock $lockfile: $!");
++ print_err("warning: Could not lock $lockfile: $!");
+ sleep 2;
+ unless (flock(LOCKF, LOCK_EX | LOCK_NB)) {
+ do_exit(1, "Could not lock $lockfile: $!");
+@@ -680,8 +681,8 @@
+ if (defined($rotlogfile)) {
+ parseFile ($rotlogfile, $spos, (stat $rotlogfile)[7]);
+ } else {
+- err("Could not open rotated logfile.");
+- err(" Tried extentions .0, .1, .01, -$today, -$yesterday");
++ print_err("Could not open rotated logfile.");
++ print_err(" Tried extentions .0, .1, .01, -$today, -$yesterday");
+ do_exit(1);
+ }
+ }
+@@ -707,7 +708,7 @@
+
+ my $err = RRDs::error;
+ if ($err) {
+- err("createRRD: $err");
++ print_err("createRRD: $err");
+ return -1;
+ }
+
+@@ -736,7 +737,7 @@
+ $last = RRDs::last($rrdfile);
+ $err = RRDs::error;
+ if ($err) {
+- err("updateRRD: $err");
++ print_err("updateRRD: $err");
+ return -1;
+ }
+
+@@ -750,8 +751,8 @@
+
+ $err = RRDs::error;
+ if ($err) {
+- err("updateRRD: $err");
+- err("Attempted to update $rrdfile at $epoch count $count");
++ print_err("updateRRD: $err");
++ print_err("Attempted to update $rrdfile at $epoch count $count");
+ return -1;
+ }
+ }
+@@ -769,7 +770,8 @@
+ print "$me: @_\n" if ($verbose);
+ }
+
+-sub err {
++sub print_err
++{
+ print STDERR "$me: error: @_\n";
+ }
+