aboutsummaryrefslogtreecommitdiff
path: root/security/amavisd-milter/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-25 22:08:42 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-25 22:08:42 +0000
commit1db56a4deaeba07b009d6e9aa8a6fd0bdef092a3 (patch)
tree4be1d6562af34a1fef940ce8397df9af333ac345 /security/amavisd-milter/Makefile
parentf80692b683f897c005c69420d1ec21e791b1ccb4 (diff)
Notes
Diffstat (limited to 'security/amavisd-milter/Makefile')
-rw-r--r--security/amavisd-milter/Makefile34
1 files changed, 31 insertions, 3 deletions
diff --git a/security/amavisd-milter/Makefile b/security/amavisd-milter/Makefile
index b7d88cef7c23..2dddaa2f9189 100644
--- a/security/amavisd-milter/Makefile
+++ b/security/amavisd-milter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= amavisd-milter
-PORTVERSION= 1.1.1
+PORTVERSION= 1.1.2
CATEGORIES= security mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,12 +16,23 @@ COMMENT= Milter for amavisd-new
RUN_DEPENDS= amavisd:${PORTSDIR}/security/amavisd-new
+##
+# Use the following quirks to choose which sendmail to use (ports or system):
+#
+# WITH_SENDMAIL_BASE=yes
+# or
+# WITH_SENDMAIL_PORT=yes
+#
+# If unspecified, check for an up-to-date system version but give an
+# installed port preference over it.
+##
+
# Shared defaults with security/amavisd-new
AMAVISUSER?= vscan
AMAVISDIR?= /var/amavis
GNU_CONFIGURE= yes
-USE_RCORDER= ${PORTNAME}.sh
+USE_RC_SUBR= ${PORTNAME}.sh
SUB_FILES= pkg-message
SUB_LIST= AMAVISUSER=${AMAVISUSER} \
@@ -34,6 +45,23 @@ PLIST_SUB= RC_DIR=${RC_DIR} \
MAN8= amavisd-milter.8
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_SENDMAIL_BASE) && \
+ !defined(WITH_SENDMAIL_PORT) && \
+ !exists(${LOCALBASE}/lib/libmilter.a)
+WITH_SENDMAIL_BASE=yes
+.endif
+
+.if defined(WITH_SENDMAIL_BASE)
+.if !exists(/usr/lib/libmilter.a)
+BROKEN= Base system sendmail not found or too old, rebuild with WITH_SENDMAIL_PORT=yes
+.endif
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
+CONFIGURE_ARGS+=--with-sendmail=${LOCALBASE}
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -43,4 +71,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>