aboutsummaryrefslogtreecommitdiff
path: root/security/amavisd-new/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-28 13:16:01 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-28 13:16:01 +0000
commit717e0f7aa1250a69563eadf6ea1709a78ad90620 (patch)
tree07dede7f27d3eb92473ce45859951209533ad54f /security/amavisd-new/Makefile
parentc001b2100d96f4ef7493d2e7a8c443e5216b25ec (diff)
downloadports-717e0f7aa1250a69563eadf6ea1709a78ad90620.tar.gz
ports-717e0f7aa1250a69563eadf6ea1709a78ad90620.zip
Notes
Diffstat (limited to 'security/amavisd-new/Makefile')
-rw-r--r--security/amavisd-new/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 6a5a29385354..5351c143c3ce 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -8,8 +8,9 @@
PORTNAME= amavisd-new
PORTVERSION= 20030616.p8
+PORTREVISION= 1
CATEGORIES= security
-MASTER_SITES= http://www.ijs.si/software/amavisd/ \
+MASTER_SITES= http://www.ijs.si/software/amavisd/ \
http://mirrors.catpipe.net/amavisd-new/ \
http://ftp.cfu.net/pub/amavisd-new/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-p/}
@@ -17,15 +18,13 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/-p/}
MAINTAINER= blaz@si.FreeBSD.org
COMMENT= Performance-enhanced daemonized version of amavis-perl
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Unix-Syslog \
${SITE_PERL}/MIME/Words.pm:${PORTSDIR}/mail/p5-MIME-Tools \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
${SITE_PERL}/${PERL_ARCH}/Convert/UUlib.pm:${PORTSDIR}/converters/p5-Convert-UUlib \
${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
- ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
${LOCALBASE}/bin/arc:${PORTSDIR}/archivers/arc \
@@ -106,7 +105,12 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500601
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.if ${PERL_LEVEL} < 500600
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/IO/Socket/UNIX.pm:${PORTSDIR}/devel/p5-IO
.endif