aboutsummaryrefslogtreecommitdiff
path: root/security/amavisd-new/Makefile
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2009-12-21 23:08:19 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2009-12-21 23:08:19 +0000
commitce2040e29e9b4dc94ff18a1d9071b6481681f979 (patch)
treebd27223a1362d3074dbb28c983e6234857b4ff7c /security/amavisd-new/Makefile
parent342bcd5b6fe842e2b245cc26cc9d6f1cbc1a721f (diff)
downloadports-ce2040e29e9b4dc94ff18a1d9071b6481681f979.tar.gz
ports-ce2040e29e9b4dc94ff18a1d9071b6481681f979.zip
Notes
Diffstat (limited to 'security/amavisd-new/Makefile')
-rw-r--r--security/amavisd-new/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 662389c68418..9017ba65b628 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -8,7 +8,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.6.4
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
@@ -46,7 +46,6 @@ AMAVISGROUP?= vscan
AMAVISDIR?= /var/amavis
AMAVISQUARANTINE?= /var/virusmails
DAEMON?= /usr/sbin/daemon -p
-HOSTNAME!= /bin/hostname
OPTIONS= BDB "Use BerkeleyDB for nanny/cache/snmp" on \
SNMP "Install amavisd snmp subagent" off \
@@ -245,7 +244,7 @@ post-patch:
-e "s|/var/lib/amavis|${AMAVISDIR}|" \
-e 's|$$log_level = 2;|$$log_level = 0;|' \
-e "s|/var/virusmails|${AMAVISQUARANTINE}|" \
- -e "s|\$localhost_name = \'localhost\';|\$localhost_name = \'${HOSTNAME}\';|g" \
+ -e 's|$$localhost_name = .localhost.;|$$localhost_name = $$myhostname;|' \
-e 's|/var/run/clamav/clamd|/var/run/clamav/clamd.sock|g' \
${WRKSRC}/${i}
.endfor
@@ -260,7 +259,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|/etc/amavisd.conf|${PREFIX}/etc/amavisd.conf|" \
-e "s|/usr/bin/perl|${PERL}|" \
-e "s|/var/amavis|${AMAVISDIR}|g" \
- -e "s|\$localhost_name = \'localhost\';|\$localhost_name = \'${HOSTNAME}\';|g" \
+ -e 's|$$localhost_name = .localhost.;|$$localhost_name = $$myhostname;|' \
${WRKSRC}/amavisd
.if defined(AMAVIS_NOAMAVIS)