aboutsummaryrefslogtreecommitdiff
path: root/security/amavisd-new
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2009-02-24 15:36:43 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2009-02-24 15:36:43 +0000
commit7cfccf3344c557b85ecf8bdd79703391da85aace (patch)
tree919c2f940618d896ab8398f339d0a874307982dc /security/amavisd-new
parent854aa4a30ea0b96bb4146c5ca4d07ec239ddd273 (diff)
downloadports-7cfccf3344c557b85ecf8bdd79703391da85aace.tar.gz
ports-7cfccf3344c557b85ecf8bdd79703391da85aace.zip
Notes
Diffstat (limited to 'security/amavisd-new')
-rw-r--r--security/amavisd-new/Makefile2
-rw-r--r--security/amavisd-new/files/amavisd.sh.in7
-rw-r--r--security/amavisd-new/files/patch-amavisd11
3 files changed, 9 insertions, 11 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 7801139fc3d2..5f5805f1c8df 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -9,7 +9,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.6.2
PORTEPOCH= 1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
http://mirrors.catpipe.net/amavisd-new/ \
diff --git a/security/amavisd-new/files/amavisd.sh.in b/security/amavisd-new/files/amavisd.sh.in
index 1a49fa688400..e5ad30f5ad18 100644
--- a/security/amavisd-new/files/amavisd.sh.in
+++ b/security/amavisd-new/files/amavisd.sh.in
@@ -49,6 +49,13 @@ stop_postcmd()
rm -f $pidfile
}
+reload_cmd=${name}_reload
+
+amavisd_reload()
+{
+ ${command} reload
+}
+
# set defaults
amavisd_enable=${amavisd_enable:-"NO"}
diff --git a/security/amavisd-new/files/patch-amavisd b/security/amavisd-new/files/patch-amavisd
index efb4e33a2b45..380920f8b9f4 100644
--- a/security/amavisd-new/files/patch-amavisd
+++ b/security/amavisd-new/files/patch-amavisd
@@ -1,5 +1,5 @@
--- amavisd.orig 2008-12-15 01:50:09.000000000 +0100
-+++ amavisd 2009-02-21 20:23:55.000000000 +0100
++++ amavisd 2009-02-24 16:28:32.000000000 +0100
@@ -1,4 +1,4 @@
-#!/usr/bin/perl -T
+#!/usr/local/bin/perl -T
@@ -25,15 +25,6 @@
or die "Can't create $pe_name file $newpart: $!";
binmode($outpart, ":bytes") or die "Can't cancel :utf8 mode: $!"
if $unicode_aware;
-@@ -13181,7 +13182,7 @@
- Amavis::Lookup::RE->new(@$Amavis::Conf::map_full_type_to_short_type_re);
-
- # default location of the config file if none specified
--push(@config_files, '/etc/amavisd.conf') if !@config_files;
-+push(@config_files, '/usr/local/etc/amavisd.conf') if !@config_files;
- # Read and evaluate config files, which may override default settings
- Amavis::Conf::include_config_files(@config_files);
- Amavis::Conf::supply_after_defaults();
@@ -18061,7 +18062,8 @@
else
{ die "File $bsmtp_file_tmp exists??? Refuse to overwrite it, $!" }