aboutsummaryrefslogtreecommitdiff
path: root/security/amavisd-new
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-07-31 07:41:04 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-07-31 07:41:04 +0000
commit85c9ccc759021f247a1e165710c50df49789455d (patch)
tree497143d8784f7ac3aa52dde4c1dc5acaa0f01fee /security/amavisd-new
parentb63ef191931ac2a027a2bb0a166d32ee7e1577bb (diff)
downloadports-85c9ccc759021f247a1e165710c50df49789455d.tar.gz
ports-85c9ccc759021f247a1e165710c50df49789455d.zip
Notes
Diffstat (limited to 'security/amavisd-new')
-rw-r--r--security/amavisd-new/Makefile50
-rw-r--r--security/amavisd-new/files/patch-amavisd35
2 files changed, 74 insertions, 11 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 70e08dcaa820..33ba8e505b54 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -8,6 +8,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.4.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
@@ -31,13 +32,6 @@ RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Unix/Syslog.pm:${PORTSDIR}/sysutils/p5-Un
${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
${SITE_PERL}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
${SITE_PERL}/${PERL_ARCH}/BerkeleyDB.pm:${PORTSDIR}/databases/p5-BerkeleyDB \
- ${LOCALBASE}/bin/arc:${PORTSDIR}/archivers/arc \
- ${LOCALBASE}/bin/unfreeze:${PORTSDIR}/archivers/freeze \
- ${LOCALBASE}/bin/lha:${PORTSDIR}/archivers/lha \
- ${LOCALBASE}/bin/lzop:${PORTSDIR}/archivers/lzop \
- ${LOCALBASE}/bin/arj:${PORTSDIR}/archivers/arj \
- ${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar \
- ${LOCALBASE}/bin/unzoo:${PORTSDIR}/archivers/unzoo \
${LOCALBASE}/bin/cabextract:${PORTSDIR}/archivers/cabextract \
${LOCALBASE}/bin/rpm2cpio.pl:${PORTSDIR}/archivers/rpm2cpio
@@ -53,7 +47,15 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.p.+//}
OPTIONS= MYSQL "MySQL support" off \
PGSQL "PgSQL support" off \
LDAP "LDAP support" off \
- MILTER "sendmail milter support" on
+ MILTER "sendmail milter support" on \
+ RAR "rar support" on \
+ ARJ "arj support" on \
+ LHA "lha support" on \
+ ARC "arc support" on \
+ ZOO "zoo support with zoo archiver" on \
+ UNZOO "zoo support with unzoo archiver" off \
+ LZOP "lzop support" on \
+ FREEZE "freeze support" on
SUB_FILES= pkg-install pkg-deinstall pkg-message
@@ -106,6 +108,38 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
RUN_DEPENDS+= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
.endif
+.if defined(WITH_RAR)
+RUN_DEPENDS+= ${LOCALBASE}/bin/unrar:${PORTSDIR}/archivers/unrar
+.endif
+
+.if defined(WITH_ARJ)
+RUN_DEPENDS+= ${LOCALBASE}/bin/arj:${PORTSDIR}/archivers/arj
+.endif
+
+.if defined(WITH_LHA)
+RUN_DEPENDS+= ${LOCALBASE}/bin/lha:${PORTSDIR}/archivers/lha
+.endif
+
+.if defined(WITH_ARC)
+RUN_DEPENDS+= ${LOCALBASE}/bin/arc:${PORTSDIR}/archivers/arc
+.endif
+
+.if defined(WITH_ZOO)
+RUN_DEPENDS+= ${LOCALBASE}/bin/zoo:${PORTSDIR}/archivers/zoo
+.endif
+
+.if defined(WITH_ZOO)
+RUN_DEPENDS+= ${LOCALBASE}/bin/unzoo:${PORTSDIR}/archivers/unzoo
+.endif
+
+.if defined(WITH_LZOP)
+RUN_DEPENDS+= ${LOCALBASE}/bin/lzop:${PORTSDIR}/archivers/lzop
+.endif
+
+.if defined(WITH_FREEZE)
+RUN_DEPENDS+= ${LOCALBASE}/bin/unfreeze:${PORTSDIR}/archivers/freeze
+.endif
+
post-patch:
.for f in amavisd.conf amavisd.conf-sample amavisd amavisd-agent amavisd-nanny amavisd-release
@${REINPLACE_CMD} ${SED_SCRIPT} -e "s@'zoo'\]@['zoo','unzoo'] ]@" ${WRKSRC}/${f}
diff --git a/security/amavisd-new/files/patch-amavisd b/security/amavisd-new/files/patch-amavisd
index 5b4203b51670..da766985392c 100644
--- a/security/amavisd-new/files/patch-amavisd
+++ b/security/amavisd-new/files/patch-amavisd
@@ -1,6 +1,6 @@
---- amavisd.orig Mon Apr 25 01:23:32 2005
-+++ amavisd Mon Apr 25 09:53:59 2005
-@@ -8495,7 +8495,7 @@
+--- amavisd.orig Tue Jun 27 13:31:56 2006
++++ amavisd Mon Jul 31 00:44:09 2006
+@@ -9335,7 +9335,7 @@
Amavis::Conf::build_default_maps();
# default location of the config file if none specified
@@ -9,3 +9,32 @@
# Read/execute the config file, which may override default settings
Amavis::Conf::read_config(@config_files);
+@@ -12049,15 +12049,20 @@
+ my($bounced) = $msginfo->dsn_sent;
+ for my $r (@{$msginfo->per_recip_data}) {
+ my($resp) = $r->recip_smtp_response;
+- if ($bounced && $smtp_resp=~/^2/ && $resp!~/^2/) {
+- # as the message was already bounced by us,
+- # MTA must not bounce it again; failure status
+- # needs to be converted into success!
+- $resp = sprintf("250 2.5.0 Ok %s, DSN %s (%s)",
+- $r->recip_addr, $bounced==1 ? 'sent' : 'muted', $resp);
++ my($recip_quoted) = qquote_rfc2821_local($r->recip_addr);
++ if ($resp=~/^2/) {
++ # success, no need to change status
++ } elsif ($bounced) {
++ # a non-delivery notifications was already sent by us, so
++ # MTA must not bounce it again; turn status into a success
++ $resp = sprintf("250 2.5.0 Ok %s, DSN was sent (%s)",
++ $recip_quoted, $resp);
++ } elsif ($resp=~/^5/ && $r->recip_destiny != D_REJECT) {
++ $resp = sprintf("250 2.5.0 Ok %s, DSN suppressed (%s)",
++ $recip_quoted, $resp);
+ }
+- do_log(4, 'sending LMTP response for <%s>: "%s"',
+- $r->recip_addr, $resp);
++ do_log(4, 'sending LMTP response for %s: "%s"',
++ $recip_quoted, $resp);
+ $self->smtp_resp(0, $resp);
+ }
+ }