aboutsummaryrefslogtreecommitdiff
path: root/security/apache-xml-security-c
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2012-10-28 20:07:39 +0000
committerGabor Pali <pgj@FreeBSD.org>2012-10-28 20:07:39 +0000
commitf0ec39444fed3d959dac15da1544d0acd17a9533 (patch)
tree94783bb0f6a7d84c5fa7184923dac9a14c1ef842 /security/apache-xml-security-c
parente27a8fab447a55eb873521f1ffae93e0a72696c3 (diff)
downloadports-f0ec39444fed3d959dac15da1544d0acd17a9533.tar.gz
ports-f0ec39444fed3d959dac15da1544d0acd17a9533.zip
Notes
Diffstat (limited to 'security/apache-xml-security-c')
-rw-r--r--security/apache-xml-security-c/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/security/apache-xml-security-c/Makefile b/security/apache-xml-security-c/Makefile
index 1e61caf00473..313269573760 100644
--- a/security/apache-xml-security-c/Makefile
+++ b/security/apache-xml-security-c/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: apache-xml-security-c
-# Date created: 06 Febuary 2007
-# Whom: Tony Maher
-#
+# Created by: Tony Maher
# $FreeBSD$
-#
PORTNAME= xml-security-c
PORTVERSION= 1.6.1
@@ -17,12 +13,16 @@ COMMENT= Apache XML security libraries - C++ version
LICENSE= AL2
-OPTIONS= XERCES_3 "With Xerces vesion 3.x (shibboleth2 requires)" on
+OPTIONS_DEFINE= XERCES_3
+OPTIONS_DEFAULT= XERCES_3
+
+XERCES_3_DESC= With Xerces vesion 3.x (shibboleth2 requires)
USE_OPENSSL= yes
-.include <bsd.port.pre.mk>
-.if defined(WITH_XERCES_3)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MXERCES_3}
LIB_DEPENDS+= xerces-c.3:${PORTSDIR}/textproc/xerces-c3
.else
LIB_DEPENDS+= xerces-c.27:${PORTSDIR}/textproc/xerces-c2
@@ -34,4 +34,5 @@ USE_AUTOTOOLS= libtool
USE_GMAKE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.include <bsd.port.post.mk>
+
+.include <bsd.port.mk>