aboutsummaryrefslogtreecommitdiff
path: root/security/arirang/Makefile
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-07-25 22:44:29 +0000
committerSteve Wills <swills@FreeBSD.org>2011-07-25 22:44:29 +0000
commit4ad820565ce607f11c74d0f1e81ff96b5753a70f (patch)
tree8efbfb2f2f77abdaaeeb4271dde6770916da7e02 /security/arirang/Makefile
parent0982b5834cdc5e7fb81f8da7b59eceb8c367960e (diff)
downloadports-4ad820565ce607f11c74d0f1e81ff96b5753a70f.tar.gz
ports-4ad820565ce607f11c74d0f1e81ff96b5753a70f.zip
Notes
Diffstat (limited to 'security/arirang/Makefile')
-rw-r--r--security/arirang/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/security/arirang/Makefile b/security/arirang/Makefile
index 1e9e85b22928..19e4d6680d72 100644
--- a/security/arirang/Makefile
+++ b/security/arirang/Makefile
@@ -7,7 +7,7 @@
PORTNAME= arirang
PORTVERSION= 2.02
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= security www
MASTER_SITES= http://monkey.org/~pilot/arirang/
@@ -24,6 +24,8 @@ USE_LIBRUBY= yes
USE_OPENSSL= yes
+CFLAGS+= -I${LOCALBASE}/include/ruby-${RUBY_VER} -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arirang ${PREFIX}/sbin
${MKDIR} ${PREFIX}/share/arirang
@@ -31,4 +33,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/scanrule/*.uxe ${PREFIX}/share/arirang
${INSTALL_DATA} ${WRKSRC}/script/*.rb ${PREFIX}/share/arirang
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ruby19
+.endif
+.include <bsd.port.post.mk>