aboutsummaryrefslogtreecommitdiff
path: root/security/arirang/Makefile
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-21 15:21:11 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-09-21 15:21:11 +0000
commit65c9395530c564a7bd08551153f5f736afd2ddcc (patch)
tree2cfb0c896b30e6ce45c064ad029738ddb6b5957e /security/arirang/Makefile
parent91057730f3b434447fb27e1d1a6b2fecc6cc219b (diff)
downloadports-65c9395530c564a7bd08551153f5f736afd2ddcc.tar.gz
ports-65c9395530c564a7bd08551153f5f736afd2ddcc.zip
Notes
Diffstat (limited to 'security/arirang/Makefile')
-rw-r--r--security/arirang/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/security/arirang/Makefile b/security/arirang/Makefile
index 716a159707ad..abe2dc47426b 100644
--- a/security/arirang/Makefile
+++ b/security/arirang/Makefile
@@ -13,18 +13,24 @@ COMMENT= Powerful webserver security scanner for network
LICENSE= BSD3CLAUSE
-BROKEN_powerpc64= fails to compile: ruby.h:1381: error: wrong number of arguments specified for '__deprecated__' attribute
-
LIB_DEPENDS= lib${RUBY_NAME}.so:${RUBY_PORT}
-USES= ssl
+USES= compiler:c11 ssl
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
CFLAGS+= -I${LOCALBASE}/include/ruby-${RUBY_VER} -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
CFLAGS+= -DRUBY_19
+
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} != base
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's/cc/${CC}/g' ${WRKSRC}/extconf.rb
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/arirang ${STAGEDIR}${PREFIX}/sbin
@@ -32,4 +38,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/scanrule/*.uxe ${STAGEDIR}${PREFIX}/share/arirang
${INSTALL_DATA} ${WRKSRC}/script/*.rb ${STAGEDIR}${PREFIX}/share/arirang
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>