aboutsummaryrefslogtreecommitdiff
path: root/security/arirang
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2011-10-04 14:51:25 +0000
committerSteve Wills <swills@FreeBSD.org>2011-10-04 14:51:25 +0000
commit348af7a78411efb6645931aa5deb62425a33ddc5 (patch)
treeda0cef55b49d1c278f0d21a0ecc21076e9439980 /security/arirang
parent3a2edac6d4f116073a95d1c25ea72a9c13ecb676 (diff)
downloadports-348af7a78411efb6645931aa5deb62425a33ddc5.tar.gz
ports-348af7a78411efb6645931aa5deb62425a33ddc5.zip
Notes
Diffstat (limited to 'security/arirang')
-rw-r--r--security/arirang/Makefile9
-rw-r--r--security/arirang/files/extra-patch-ruby1919
-rw-r--r--security/arirang/files/patch-ariruby.c48
3 files changed, 2 insertions, 74 deletions
diff --git a/security/arirang/Makefile b/security/arirang/Makefile
index 19e4d6680d72..db7df29728d8 100644
--- a/security/arirang/Makefile
+++ b/security/arirang/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= arirang
-PORTVERSION= 2.02
-PORTREVISION= 2
+PORTVERSION= 2.03
PORTEPOCH= 1
CATEGORIES= security www
MASTER_SITES= http://monkey.org/~pilot/arirang/
@@ -33,8 +32,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/scanrule/*.uxe ${PREFIX}/share/arirang
${INSTALL_DATA} ${WRKSRC}/script/*.rb ${PREFIX}/share/arirang
-.include <bsd.port.pre.mk>
-.if ${RUBY_VER} == 1.9
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-ruby19
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/arirang/files/extra-patch-ruby19 b/security/arirang/files/extra-patch-ruby19
deleted file mode 100644
index ef7b1551f326..000000000000
--- a/security/arirang/files/extra-patch-ruby19
+++ /dev/null
@@ -1,19 +0,0 @@
---- ariruby.c.orig 2011-07-24 21:50:51.119557755 -0400
-+++ ariruby.c 2011-07-24 21:52:04.985558821 -0400
-@@ -63,6 +63,7 @@
-
- static int sock;
- int nb = 0;
-+void* rb_load_file_return;
- struct sockaddr_in http;
- struct hostent *he;
- char *sendbuf = NULL;
-@@ -132,7 +133,7 @@
- ariruby_run(void)
- {
- int status;
-- status = ruby_exec();
-+ status = ruby_run_node(rb_load_file_return);
- #ifdef DEBUG
- printf("status = %d \n", status);
- #endif
diff --git a/security/arirang/files/patch-ariruby.c b/security/arirang/files/patch-ariruby.c
deleted file mode 100644
index 2a057ad26349..000000000000
--- a/security/arirang/files/patch-ariruby.c
+++ /dev/null
@@ -1,48 +0,0 @@
---- ariruby.c.orig 2011-04-27 21:34:36.000000000 -0400
-+++ ariruby.c 2011-07-24 21:50:51.119557755 -0400
-@@ -189,7 +189,7 @@
- static VALUE
- ariprint(VALUE self, VALUE outbuf)
- {
-- fprintf(stdout, "%s", RSTRING(outbuf)->ptr);
-+ fprintf(stdout, "%s", RSTRING_PTR(outbuf));
-
- return self;
- }
-@@ -198,14 +198,14 @@
- arisend(VALUE self, VALUE data)
- {
- int len;
-- len = RSTRING(data)->len;
-+ len = RSTRING_LEN(data);
-
- if ((sendbuf = (char *)malloc(len + 1)) == NULL) {
- perror("arisend malloc failed");
- close(sock);
- exit(0);
- }
-- memcpy(sendbuf, RSTRING(data)->ptr, len);
-+ memcpy(sendbuf, RSTRING_PTR(data), len);
-
- if (len == 0) {
- fprintf(stderr, "please set a data in arisend function \n");
-@@ -519,9 +519,6 @@
- if (sendbuf != NULL)
- free(sendbuf);
-
-- if (headbuf != NULL)
-- free(headbuf);
--
- if (nb == -1 || nb == -2) {
- #if !(defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__))
- alarm(0);
-@@ -544,6 +541,9 @@
- exit(0);
- }
-
-+ if (headbuf != NULL)
-+ free(headbuf);
-+
- if (sslflags)
- ssl_free(ctx, ssl);
-