aboutsummaryrefslogtreecommitdiff
path: root/security/arirang
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-04-29 04:53:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-04-29 04:53:50 +0000
commitfae396e41ac770ec6cf0f772a57ca460fcc88c34 (patch)
treece8bc0be3ae2b0a17fbf772f3940b79996863f0b /security/arirang
parent5f7e53be98829466b03a9259ba7f9ecb2ed83093 (diff)
downloadports-fae396e41ac770ec6cf0f772a57ca460fcc88c34.tar.gz
ports-fae396e41ac770ec6cf0f772a57ca460fcc88c34.zip
- add a patch to fix a use-after-free
- bump portrevision Submitted by: pilot <pilot@monkey.org> (upstream) (by mail) Obtained from: OpenBSD port
Notes
Notes: svn path=/head/; revision=273313
Diffstat (limited to 'security/arirang')
-rw-r--r--security/arirang/Makefile1
-rw-r--r--security/arirang/files/patch-ariruby.c22
2 files changed, 23 insertions, 0 deletions
diff --git a/security/arirang/Makefile b/security/arirang/Makefile
index 5c07e89777a3..1e9e85b22928 100644
--- a/security/arirang/Makefile
+++ b/security/arirang/Makefile
@@ -7,6 +7,7 @@
PORTNAME= arirang
PORTVERSION= 2.02
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security www
MASTER_SITES= http://monkey.org/~pilot/arirang/
diff --git a/security/arirang/files/patch-ariruby.c b/security/arirang/files/patch-ariruby.c
new file mode 100644
index 000000000000..b44c4f587eb5
--- /dev/null
+++ b/security/arirang/files/patch-ariruby.c
@@ -0,0 +1,22 @@
+--- ariruby.c.orig Fri Apr 29 09:23:11 2011
++++ ariruby.c Fri Apr 29 09:24:14 2011
+@@ -519,9 +519,6 @@
+ if (sendbuf != NULL)
+ free(sendbuf);
+
+- if (headbuf != NULL)
+- free(headbuf);
+-
+ if (nb == -1 || nb == -2) {
+ #if !(defined(__OpenBSD__) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__APPLE__))
+ alarm(0);
+@@ -543,6 +540,9 @@
+ if (!pflags)
+ exit(0);
+ }
++
++ if (headbuf != NULL)
++ free(headbuf);
+
+ if (sslflags)
+ ssl_free(ctx, ssl);