aboutsummaryrefslogtreecommitdiff
path: root/security/autossh/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2003-10-06 23:49:25 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2003-10-06 23:49:25 +0000
commitca0bdb3bffad6ccf7e3cac7f2d05f5832db602b0 (patch)
tree72c986b6274b340fb384b8fd7cf7897b1aa1224e /security/autossh/Makefile
parentbfc61041b6e8213b49e0a828be1e6ab9c9aafb9b (diff)
downloadports-ca0bdb3bffad6ccf7e3cac7f2d05f5832db602b0.tar.gz
ports-ca0bdb3bffad6ccf7e3cac7f2d05f5832db602b0.zip
Notes
Diffstat (limited to 'security/autossh/Makefile')
-rw-r--r--security/autossh/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/security/autossh/Makefile b/security/autossh/Makefile
new file mode 100644
index 000000000000..4e077696c0f4
--- /dev/null
+++ b/security/autossh/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: autossh
+# Date created: 26 December 2002
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autossh
+PORTVERSION= 1.2d
+CATEGORIES= security
+MASTER_SITES= http://www.harding.motd.ca/autossh/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= Automatically restart SSH sessions and tunnels
+
+MAKEFILE= Makefile.bsd
+USE_REINPLACE= yes
+
+MAN1= autossh.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,cp autossh.1 ,$$\{BSD_INSTALL_MAN\} autossh.1 ,g' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's,cp autossh ,$$\{BSD_INSTALL_PROGRAM\} autossh ,g' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e 's,cp ,$$\{BSD_INSTALL_DATA\} ,g' ${WRKSRC}/${MAKEFILE}
+
+.include <bsd.port.mk>