aboutsummaryrefslogtreecommitdiff
path: root/security/avmailgate
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-05 09:40:55 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-05 09:40:55 +0000
commit34608fcaa3d1cd360f3fe3a80f910ed0e4968d37 (patch)
tree96a38954f26daf6a67123fdd5328ae30e1425b03 /security/avmailgate
parent92908c7190d8cd337361a7b983e6c111f331245b (diff)
Notes
Diffstat (limited to 'security/avmailgate')
-rw-r--r--security/avmailgate/Makefile65
-rw-r--r--security/avmailgate/distinfo1
-rw-r--r--security/avmailgate/files/avmailgate.sh26
-rw-r--r--security/avmailgate/files/diff.rc7
-rw-r--r--security/avmailgate/files/patch-aa21
-rw-r--r--security/avmailgate/pkg-descr34
-rw-r--r--security/avmailgate/pkg-plist15
7 files changed, 169 insertions, 0 deletions
diff --git a/security/avmailgate/Makefile b/security/avmailgate/Makefile
new file mode 100644
index 000000000000..03814e8c18c2
--- /dev/null
+++ b/security/avmailgate/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: avmailgate
+# Version required: 6.12
+# Date created: January 29, 2002
+# Whom: Oliver Breuninger <ob@breuninger.org>
+#
+# $FreeBSD$
+
+#
+# http://www.antivir.de/dateien/antivir/fuse6/fuse6.zip
+#
+
+PORTNAME= avmailgate
+PORTVERSION= 6.12
+DISTFILES= avmailgate-6.12.0.0-freebsd.tgz
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.antivir.de/freebsd/distfiles/
+MAINTAINER= ob@breuninger.org
+
+WRKSRC= ${WRKDIR}/avmailgate-6.12.0.0-FreeBSD
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${LOCALBASE}/etc/antivir
+ @${MKDIR} /var/spool/avmailgate
+ @${MKDIR} /var/spool/avmailgate/incoming
+ @${MKDIR} /var/spool/avmailgate/outgoing
+ @${MKDIR} /var/spool/avmailgate/rejected
+ @${CHOWN} -R daemon:daemon /var/spool/avmailgate
+ @${CHMOD} 0700 /var/spool/avmailgate
+ @${CHMOD} 0700 /var/spool/avmailgate/incoming
+ @${CHMOD} 0700 /var/spool/avmailgate/rejected
+ @${CHMOD} 0700 /var/spool/avmailgate/outgoing
+ @${LN} -fs ${LOCALBASE}/etc/antivir /usr/lib/AntiVir
+ @${LN} -fs ${LOCALBASE}/etc/antivir/avmailgate.acl /etc/avmailgate.acl
+ @${LN} -fs ${LOCALBASE}/etc/antivir/avmailgate.conf /etc/avmailgate.conf
+ @${CP} -p ${FILESDIR}/avmailgate.sh ${LOCALBASE}/etc/rc.d
+ @${CP} -p ${WRKSRC}/antivir.vdf ${LOCALBASE}/etc/antivir
+ @${CP} -p ${WRKSRC}/avmailgate/avgated ${LOCALBASE}/sbin
+ @${CP} -p ${WRKSRC}/avmailgate/script/avq ${LOCALBASE}/sbin
+ @${CP} -p ${WRKSRC}/avmailgate/avgatefwd ${LOCALBASE}/sbin
+ @${CP} -p ${WRKSRC}/avmailgate/etc/avmailgate.* ${LOCALBASE}/etc/antivir
+ @${CP} -p ${WRKSRC}/avmailgate/man/*.5 ${LOCALBASE}/man/man5
+ @${CP} -p ${WRKSRC}/avmailgate/man/*.8 ${LOCALBASE}/man/man8
+
+post-install:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "******************************************************************"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "For full functionality of AntiVir MailGate you need an license key"
+ @${ECHO_MSG} "from H+BEDV Datentechnik GmbH."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "Put the file avmgate.key into the directory /usr/local/etc/antivir"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "For more information on AntiVir please visit our web site"
+ @${ECHO_MSG} "http://www.antivir.de or http://www.hbedv.com."
+ @${ECHO_MSG} "mailto: support@antivir.de"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "AntiVir is a registered trademark of H+BEDV Datentechnik GmbH"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "******************************************************************"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
+
diff --git a/security/avmailgate/distinfo b/security/avmailgate/distinfo
new file mode 100644
index 000000000000..483d3232585d
--- /dev/null
+++ b/security/avmailgate/distinfo
@@ -0,0 +1 @@
+MD5 (avmailgate-6.12.0.0-freebsd.tgz) = 0673cc1ef6ef1b4119a491b1b460dccc
diff --git a/security/avmailgate/files/avmailgate.sh b/security/avmailgate/files/avmailgate.sh
new file mode 100644
index 000000000000..201ec5ea9f87
--- /dev/null
+++ b/security/avmailgate/files/avmailgate.sh
@@ -0,0 +1,26 @@
+#! /bin/sh
+
+case "$1" in
+ start)
+ echo "Initializing SMTP port. (avmailgate)"
+ /usr/local/sbin/avgated -A /usr/local/etc/antivir/avmailgate.acl -C /usr/local/etc/antivir/avmailgate.conf &
+ /usr/local/sbin/avgatefwd -C /usr/local/etc/antivir/avmailgate.conf &
+ ;;
+ stop)
+ echo -n "Shutting down SMTP port:"
+ echo
+ kill `cat /var/run/avmailgate_d.pid`
+ kill `cat /var/run/avmailgate_fwd.pid`
+ ;;
+ restart)
+ "$0" stop
+ "$0" start
+ ;;
+ *)
+ echo "Usage: $0 {start|stop|restart}"
+ exit 1
+ ;;
+esac
+
+exit 0
+
diff --git a/security/avmailgate/files/diff.rc b/security/avmailgate/files/diff.rc
new file mode 100644
index 000000000000..93c94e66282a
--- /dev/null
+++ b/security/avmailgate/files/diff.rc
@@ -0,0 +1,7 @@
+#! /bin/csh
+#
+
+cd ../work/avmailgate-6.12.0.0-FreeBSD
+
+diff --unified=2 avmailgate/etc/avmailgate.conf.orig avmailgate/etc/avmailgate.conf > ../../patch-aa
+
diff --git a/security/avmailgate/files/patch-aa b/security/avmailgate/files/patch-aa
new file mode 100644
index 000000000000..1817d6c8a8e5
--- /dev/null
+++ b/security/avmailgate/files/patch-aa
@@ -0,0 +1,21 @@
+--- avmailgate/etc/avmailgate.conf.orig Mon Jan 28 10:38:57 2002
++++ avmailgate/etc/avmailgate.conf Wed Jan 30 00:00:22 2002
+@@ -22,4 +22,6 @@
+ # User uucp
+ # Group uucp
++User daemon
++Group daemon
+
+ # ------------------------------------------------------------------------
+@@ -47,4 +49,5 @@
+
+ # AntiVirDir /usr/lib/AntiVir
++AntiVirDir /usr/local/etc/antivir
+
+ # ------------------------------------------------------------------------
+@@ -207,4 +210,5 @@
+
+ # ForwardTo /usr/lib/sendmail -oem -oi
++ForwardTo /usr/sbin/sendmail -oem -oi
+
+ # Or if you want the mail to be sent by SMTP:
diff --git a/security/avmailgate/pkg-descr b/security/avmailgate/pkg-descr
new file mode 100644
index 000000000000..ab0ecba5ad5a
--- /dev/null
+++ b/security/avmailgate/pkg-descr
@@ -0,0 +1,34 @@
+AntiVir MailGate for FreeBSD protects your electronic post office
+against viruses.
+It is working with numerous common Mail Transport Agents (MTA),
+like sendmail, postfix, qmail and exim. Operates at high speed,
+is easy to configure and checks both incoming and outgoing emails.
+
+AntiVir MailGate is a store-and-forward agent, in which the
+workload is shared by the two programs avgated and avgatefwd.
+
+Avgated receives the emails and stores them in a specified
+directory. This program can be run as an independent server which
+occupies port 25 (SMTP) or is started by the internet superdaemon
+inetd.
+
+Avgatefwd reads the temporarily stored emails, decodes the attach-
+ments and initiates the virus scan. If no viruses are found in the
+emails, they are forwarded immediately.
+
+If an email is found to be infected, it will not be forwarded. In
+this case, the postmaster receives an e-mail with a detailed report,
+and the sender and recipient are also notified of the infection.
+
+*********************************************************************
+ For more information on AntiVir please visit our web site
+ http://www.antivir.de/
+ or
+ http://www.hbedv.com/
+
+ AntiVir is a registered trademark of
+ H+BEDV Datentechnik GmbH
+*********************************************************************
+
+WWW: http://www.antivir.de/
+WWW: http://www.hbedv.com/
diff --git a/security/avmailgate/pkg-plist b/security/avmailgate/pkg-plist
new file mode 100644
index 000000000000..614f3c889cab
--- /dev/null
+++ b/security/avmailgate/pkg-plist
@@ -0,0 +1,15 @@
+etc/antivir/antivir.vdf
+etc/antivir/avmailgate.conf
+etc/antivir/avmailgate.conf.orig
+etc/antivir/avmailgate.acl
+etc/rc.d/avmailgate.sh
+sbin/avgated
+sbin/avgatefwd
+sbin/avq
+man/man8/avmailgate.8
+man/man5/avmailgate.conf.5
+@unexec rm -r /usr/local/etc/antivir
+@unexec rmdir /var/spool/avmailgate/incoming
+@unexec rmdir /var/spool/avmailgate/outgoing
+@unexec rmdir /var/spool/avmailgate/rejected
+@unexec rmdir /var/spool/avmailgate