aboutsummaryrefslogtreecommitdiff
path: root/security/barnyard2
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-12-02 12:56:59 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-12-02 12:56:59 +0000
commit1a08b304c193fb6e2699837566626a85ed290f37 (patch)
tree05c8aa715bb15096a6d81d86524e4e9cb3e792ea /security/barnyard2
parentde2db4fa37b6e703eee8b06afa8902b6bbf6089f (diff)
downloadports-1a08b304c193fb6e2699837566626a85ed290f37.tar.gz
ports-1a08b304c193fb6e2699837566626a85ed290f37.zip
Notes
Diffstat (limited to 'security/barnyard2')
-rw-r--r--security/barnyard2/Makefile109
-rw-r--r--security/barnyard2/distinfo4
-rw-r--r--security/barnyard2/files/patch-etc__Makefile.am8
-rw-r--r--security/barnyard2/files/pkg-message.in8
-rw-r--r--security/barnyard2/pkg-plist8
5 files changed, 90 insertions, 47 deletions
diff --git a/security/barnyard2/Makefile b/security/barnyard2/Makefile
index e6147f67ba4f..ea2c06142525 100644
--- a/security/barnyard2/Makefile
+++ b/security/barnyard2/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= barnyard2
-PORTVERSION= 1.10
-PORTREVISION?= 0
+PORTVERSION= 1.11
CATEGORIES= security
MAINTAINER= pauls@utdallas.edu
@@ -13,22 +12,23 @@ LICENSE= GPLv2
USE_GITHUB= yes
GH_ACCOUNT= firnsy
GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= v2-${PORTVERSION}
-GH_COMMIT= 2f5d496
+GH_TAGNAME= master
+GH_COMMIT= 4dfdc80
-OPTIONS_DEFINE= MYSQL PGSQL BRO SNORT SNORTSAM SURICATA
-OPTIONS_DEFAULT=#empty
+OPTIONS_DEFINE= 64BIT ARUBA BRO GRE IPV6 MPLS MYSQL MYSQL-SSL ODBC PRELUDE PGSQL
NO_OPTIONS_SORT=yes
-BRO_DESC= Depend on security/bro
-MYSQL_DESC= Enable MySQL support
-PGSQL_DESC= Enable PostgreSQL support
-SNORT_DESC= Depend on security/snort
-SNORTSAM_DESC= Depend on security/snortsam
-SURICATA_DESC= Depend on security/suricata
-
-.if !defined(SLAVE)
-OPTIONS_DEFINE+=TCL
+64BIT_DESC= Enable 64bit compilation (experimental)
+ARUBA_DESC= Enable aruba support
+BRO_DESC= Enable bro support (libbroccoli)
+GRE_DESC= Enable gre support
+MYSQL-SSL_DESC= Enable mysql ssl support (experimental)
+PRELUDE_DESC= Enable prelude support
+
+.if defined(SLAVE)
+OPTIONS_DEFINE+= TCL
+OPTIONS_DESC= Enable tcl support for sguil
+OPTIONS_DEFAULT+= TCL
.endif
USE_AUTOTOOLS= libtoolize aclocal autoheader automake autoconf
@@ -44,45 +44,83 @@ SUB_FILES= pkg-message
PORTDOCS1= README RELEASE.NOTES
PORTDOCS2= INSTALL README.aruba README.database README.sguil README.snortsam
-PORTEXAMPLES= create_db2 create_mysql create_postgresql SCHEMA_ACCESS create_mssql create_oracle.sql
-PORTDOCS= ${PORTDOCS1} ${PORTDOCS2}
+PORTEXAMPLES= SCHEMA_ACCESS create_db2 create_mssql create_mysql create_oracle.sql create_postgresql
.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:M64BIT}
+CONFIGURE_ARGS+= --enable-64bit-gcc
+.else
+CONFIGURE_ARGS+= --disable-64bit-gcc
+.endif
+
+.if ${PORT_OPTIONS:MARUBA}
+CONFIGURE_ARGS+= --enable-aruba
+.else
+CONFIGURE_ARGS+= --disable-aruba
+.endif
+
+.if ${PORT_OPTIONS:MBRO}
+BROKEN= Will not compile until bro update is committed - deselect this option
+BUILD_DEPENDS+= bro:${PORTSDIR}/security/bro-barnyard2
+CONFIGURE_ARGS+= --enable-bro --with-broccoli=${LOCALBASE}/lib
+.else
+CONFIGURE_ARGS+= --disable-bro
+.endif
+
+.if ${PORT_OPTIONS:MGRE}
+CONFIGURE_ARGS+= --enable-gre
+.else
+CONFIGURE_ARGS+= --disable-gre
+.endif
+
+.if ${PORT_OPTIONS:MIPV6}
+CONFIGURE_ARGS+= --enable-ipv6
+.else
+CONFIGURE_ARGS+= --disable-ipv6
+.endif
+
+.if ${PORT_OPTIONS:MMPLS}
+CONFIGURE_ARGS+= --enable-mpls
+.else
+CONFIGURE_ARGS+= --disable-mpls
+.endif
+
.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
CONFIGURE_ARGS+= --with-mysql \
--with-mysql-includes=${LOCALBASE}/include/mysql \
--with-mysql-libraries=${LOCALBASE}/lib/mysql
-SUB_LIST+= MYSQL=" mysql"
.else
CONFIGURE_ARGS+= --without-mysql
-SUB_LIST+= MYSQL=""
.endif
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
-CONFIGURE_ARGS+= --with-postgresql=${LOCALBASE}
-SUB_LIST+= PGSQL=" postgresql"
+.if ${PORT_OPTIONS:MMYSQL-SSL}
+OPTIONS_DEFAULT+= MYSQL
+CONFIGURE_ARGS+= --enable-mysql-ssl-support
.else
-CONFIGURE_ARGS+= --without-postgresql
-SUB_LIST+= PGSQL=""
-.endif
-
-.if ${PORT_OPTIONS:MBRO}
-RUN_DEPENDS+= ${LOCALBASE}/bin/bro:${PORTSDIR}/security/bro
+CONFIGURE_ARGS+= --disable-mysql-ssl-support
.endif
-.if ${PORT_OPTIONS:MSNORT}
-RUN_DEPENDS+= ${LOCALBASE}/bin/snort:${PORTSDIR}/security/snort
+.if ${PORT_OPTIONS:MODBC}
+LIB_DEPENDS+= odbc:${PORTSDIR}/databases/unixODBC
+CONFIGURE_ARGS+= --with-odbc
+.else
+CONFIGURE_ARGS+= --without-odbc
.endif
-.if ${PORT_OPTIONS:MSNORTSAM}
-RUN_DEPENDS+= ${LOCALBASE}/bin/snortsnam:${PORTSDIR}/security/snortsam
+.if ${PORT_OPTIONS:MPRELUDE}
+BUILD_DEPENDS+= prelude-manager:${PORTSDIR}/security/prelude-manager
+CONFIGURE_ARGS+= --enable-prelude
+.else
+CONFIGURE_ARGS+= --disable-prelude
.endif
-.if ${PORT_OPTIONS:MSURICATA}
-RUN_DEPENDS+= ${LOCALBASE}/bin/suricata:${PORTSDIR}/security/suricata
+.if ${PORT_OPTIONS:MPGSQL}
+USE_PGSQL= yes
+CONFIGURE_ARGS+= --with-postgresql=${LOCALBASE}/bin/pg_config --with-pgsql-includes=${LOCALBASE}/include/postgresql/server
+.else
+CONFIGURE_ARGS+= --without-postgresql
.endif
.if ${PORT_OPTIONS:MTCL}
@@ -97,6 +135,7 @@ post-patch:
${WRKSRC}/etc/barnyard2.conf
post-install:
+ @cp ${WRKSRC}/etc/barnyard2.conf ${PREFIX}/etc/barnyard2.conf.sample
if [ ! -f ${PREFIX}/etc/barnyard2.conf ]; then \
${CP} -p ${PREFIX}/etc/barnyard2.conf.sample ${PREFIX}/etc/barnyard2.conf; \
fi
diff --git a/security/barnyard2/distinfo b/security/barnyard2/distinfo
index c33116663cbf..0347dd78f5b3 100644
--- a/security/barnyard2/distinfo
+++ b/security/barnyard2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (barnyard2-1.10.tar.gz) = 31d4e3745606489658bd411f74ffeb8a27573fdc08d0b51a6a71e1bf4dece8a2
-SIZE (barnyard2-1.10.tar.gz) = 419781
+SHA256 (barnyard2-1.11.tar.gz) = 345d6dfd7f88cc7d72258338e2db0fa05499dc434c0fe33b685d998f497f2bcd
+SIZE (barnyard2-1.11.tar.gz) = 425392
diff --git a/security/barnyard2/files/patch-etc__Makefile.am b/security/barnyard2/files/patch-etc__Makefile.am
deleted file mode 100644
index a2ec88bb3e5f..000000000000
--- a/security/barnyard2/files/patch-etc__Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
---- ./etc/Makefile.am.orig 2012-10-08 10:03:32.000000000 -0400
-+++ ./etc/Makefile.am 2012-10-08 10:05:02.000000000 -0400
-@@ -4,4 +4,4 @@
- EXTRA_DIST = barnyard2.conf
-
- install-data-am:
-- test -e $(sysconfdir)/barnyard2.conf || install -m 600 $(top_srcdir)/etc/barnyard2.conf $(sysconfdir)
-+ install -m 600 $(top_srcdir)/etc/barnyard2.conf $(sysconfdir)/barnyard2.conf.sample
diff --git a/security/barnyard2/files/pkg-message.in b/security/barnyard2/files/pkg-message.in
index 577e6d1ff69d..c782d838d593 100644
--- a/security/barnyard2/files/pkg-message.in
+++ b/security/barnyard2/files/pkg-message.in
@@ -1,12 +1,16 @@
-Read the notes in the barnyard2.conf file for how to configure
+Read the notes in the barnyard2.conf file for how to configure
%%PREFIX%%/etc/barnyard2.conf after installation. For addtional information
see the Securixlive FAQ at http://www.securixlive.com/barnyard2/faq.php.
-In order to enable barnyard2 to start on boot, you must edit /etc/rc.conf
+In order to enable barnyard2 to start on boot, you must edit /etc/rc.conf
with the appropriate flags, etc. See the FreeBSD Handbook for syntax:
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/configtuning-rcng.html
For the various options available, type % barnyard2 -h after install or read
the options in the startup script - in %%PREFIX%%/etc/rc.d.
+Barnyard2 can process unified2 files from snort or suricata. It can also
+interact with snortsam firewall rules as well as the sguil-sensor. Those
+ports must be installed separately if you wish to use them.
+
************************************************************************
diff --git a/security/barnyard2/pkg-plist b/security/barnyard2/pkg-plist
index b5cdf006379c..79edf53a0f6d 100644
--- a/security/barnyard2/pkg-plist
+++ b/security/barnyard2/pkg-plist
@@ -2,3 +2,11 @@ bin/barnyard2
@unexec if cmp -s %D/etc/barnyard2.conf %D/etc/barnyard2.conf.sample; then rm -f %D/etc/barnyard2.conf; fi
etc/barnyard2.conf.sample
@exec [ -f %B/barnyard2.conf ] || cp -p %B/%f %B/barnyard2.conf
+%%DOCSDIR%%/INSTALL
+%%DOCSDIR%%/README
+%%DOCSDIR%%/README.aruba
+%%DOCSDIR%%/README.database
+%%DOCSDIR%%/README.sguil
+%%DOCSDIR%%/README.snortsam
+%%DOCSDIR%%/RELEASE.NOTES
+@dirrm %%DOCSDIR%%