aboutsummaryrefslogtreecommitdiff
path: root/security/bcrypt/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-09-03 19:03:17 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-09-03 19:03:17 +0000
commit65677c952165e41c22edaac594b3b31085282fbd (patch)
tree2418abf2263d25b8ebfbd1e761fcc42cbd70f4a2 /security/bcrypt/Makefile
parent80d042808a4722a0ed36038d1ce5f793ca27bf2e (diff)
downloadports-65677c952165e41c22edaac594b3b31085282fbd.tar.gz
ports-65677c952165e41c22edaac594b3b31085282fbd.zip
Notes
Diffstat (limited to 'security/bcrypt/Makefile')
-rw-r--r--security/bcrypt/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/security/bcrypt/Makefile b/security/bcrypt/Makefile
new file mode 100644
index 000000000000..929493b6c88c
--- /dev/null
+++ b/security/bcrypt/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: bcrypt
+# Date created: 11 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bcrypt
+PORTVERSION= 1.1
+CATEGORIES= security
+MASTER_SITES= http://bcrypt.sourceforge.net/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A cross-plattform blowfish encryption utility
+
+USE_REINPLACE= yes
+
+ALL_TARGET= ${PORTNAME}
+
+LDFLAGS+= -lz
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
+PORTDOCS= README
+MAN1= bcrypt.1
+PLIST_FILES= bin/bcrypt
+
+post-patch:
+ @${REINPLACE_CMD} -E 's/^(CC|CFLAGS|LDFLAGS|PREFIX)\ /\1?/' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>