aboutsummaryrefslogtreecommitdiff
path: root/security/bcwipe/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-03-11 16:08:10 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-03-11 16:08:10 +0000
commite2415806bfe56fcee6459f888a3d0443a0c8311e (patch)
treedc36e8caf55c7ca4c41a51c1e78cc409b4598973 /security/bcwipe/Makefile
parent3f0493440405689066addc28581541bf547ea01e (diff)
downloadports-e2415806bfe56fcee6459f888a3d0443a0c8311e.tar.gz
ports-e2415806bfe56fcee6459f888a3d0443a0c8311e.zip
Notes
Diffstat (limited to 'security/bcwipe/Makefile')
-rw-r--r--security/bcwipe/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/bcwipe/Makefile b/security/bcwipe/Makefile
index 838381433a9b..62d49ba3d473 100644
--- a/security/bcwipe/Makefile
+++ b/security/bcwipe/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= bcwipe
-PORTVERSION= 1.2.3
+PORTVERSION= 1.5.3
CATEGORIES= security
MASTER_SITES= http://www.jetico.com/linux/ \
- http://www.underworld.hu/~crow/distfiles/
+ http://www.bsdberlin.org/~dako/distfiles/security/
DISTNAME= BCWipe-${PORTVERSION:S/./-/g:S/-/./}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= BCWipe securely erase data from magnetic and solid-state memory
+MAINTAINER= dako@bsdberlin.org
+COMMENT= BCWipe securely erases data from magnetic and solid-state memory
NO_CDROM= yes
USE_REINPLACE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+CFLAGS+= -DOS_FreeBSD
MAN1= bcwipe.1
PLIST_FILES= bin/bcwipe
@@ -25,6 +26,8 @@ PLIST_FILES= bin/bcwipe
post-patch:
@${REINPLACE_CMD} -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e "s,fprintf(stderr\,string),fprintf(stderr\,\"%s\"\,string),g" ${WRKSRC}/wipe.c
+ @${REINPLACE_CMD} -e "s,if (NULL == mktemp(result)),if (mkstemp(result) == -1),g" ${WRKSRC}/wipe.c
+ @${REINPLACE_CMD} -e "s,mktemp,mkstemp,g" ${WRKSRC}/wipe.c
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/bcwipe ${PREFIX}/bin