aboutsummaryrefslogtreecommitdiff
path: root/security/bcwipe
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-06 17:08:40 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-06 17:08:40 +0000
commitc27f7afd9668d66156eebdf82d066c257f170b32 (patch)
treeabc42320aaf6efb2dc2ccb94044c071a59f2e8ef /security/bcwipe
parent267520c662d1f6bc8e265fbf1230c89e8a2cabb2 (diff)
downloadports-c27f7afd9668d66156eebdf82d066c257f170b32.tar.gz
ports-c27f7afd9668d66156eebdf82d066c257f170b32.zip
Notes
Diffstat (limited to 'security/bcwipe')
-rw-r--r--security/bcwipe/Makefile27
-rw-r--r--security/bcwipe/distinfo1
-rw-r--r--security/bcwipe/pkg-comment1
-rw-r--r--security/bcwipe/pkg-descr5
-rw-r--r--security/bcwipe/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/security/bcwipe/Makefile b/security/bcwipe/Makefile
new file mode 100644
index 000000000000..210353927403
--- /dev/null
+++ b/security/bcwipe/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: bcwipe
+# Date created: Mar 4, 2001
+# Whom: crow
+#
+# $FreeBSD$
+#
+
+PORTNAME= bcwipe
+PORTVERSION= 0.2.3
+CATEGORIES= security
+MASTER_SITES= http://www.jetico.com/linux/
+DISTNAME= BCWipe-0.2-3
+
+MAINTAINER= crow@nektor.hu
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.2-3
+
+MAN1= bcwipe.1
+
+post-patch:
+ @${PERL} -pi -e "s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/bcwipe ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/bcwipe.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/bcwipe/distinfo b/security/bcwipe/distinfo
new file mode 100644
index 000000000000..73852557344c
--- /dev/null
+++ b/security/bcwipe/distinfo
@@ -0,0 +1 @@
+MD5 (BCWipe-0.2-3.tar.gz) = 8e0d50d42b9cf5256f4a890811721d5c
diff --git a/security/bcwipe/pkg-comment b/security/bcwipe/pkg-comment
new file mode 100644
index 000000000000..e5bfb20a726a
--- /dev/null
+++ b/security/bcwipe/pkg-comment
@@ -0,0 +1 @@
+BCWipe securely erase data from magnetic and solid-state memory
diff --git a/security/bcwipe/pkg-descr b/security/bcwipe/pkg-descr
new file mode 100644
index 000000000000..54bd36e6a87b
--- /dev/null
+++ b/security/bcwipe/pkg-descr
@@ -0,0 +1,5 @@
+bcwipe Repeatedly overwrites special patterns to the files
+to be destroyed. In normal mode, 34 patterns are used (of
+which 8 are random).
+
+WWW: http://www.jetico.com/
diff --git a/security/bcwipe/pkg-plist b/security/bcwipe/pkg-plist
new file mode 100644
index 000000000000..33e198e6e371
--- /dev/null
+++ b/security/bcwipe/pkg-plist
@@ -0,0 +1 @@
+bin/bcwipe