aboutsummaryrefslogtreecommitdiff
path: root/security/bdc/Makefile
diff options
context:
space:
mode:
authorNiels Heinen <niels@FreeBSD.org>2005-06-05 13:36:22 +0000
committerNiels Heinen <niels@FreeBSD.org>2005-06-05 13:36:22 +0000
commit64101141a14c401cdfb68bd4afec68dbc7e01d2b (patch)
treeecfcb050768a1173b65613ebb270c42da3d0af6d /security/bdc/Makefile
parentdd8a978938895ca47f7441835bfebcde75664c8a (diff)
Notes
Diffstat (limited to 'security/bdc/Makefile')
-rw-r--r--security/bdc/Makefile66
1 files changed, 66 insertions, 0 deletions
diff --git a/security/bdc/Makefile b/security/bdc/Makefile
new file mode 100644
index 000000000000..8d072c5c80a4
--- /dev/null
+++ b/security/bdc/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: bdc
+# Date created: 4 December 2004
+# Whom: Adi Pircalabu <apircalabu@bitdefender.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bdc
+PORTVERSION= 7.0.1
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.bitdefender.com/pub/freebsd/${BDREL}/beta/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-fbsd${BDREL}
+
+MAINTAINER= apircalabu@bitdefender.com
+COMMENT= BitDefender Console Antivirus for FreeBSD
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 490000 || ${OSVERSION} >= 500000 && ${OSVERSION} < 502001
+IGNORE= "requires FreeBSD-STABLE \(4.9 or later\), or FreeBSD-CURRENT \(5.2.1 or later\)"
+.elif ${OSVERSION} < 500000
+BDREL= 4
+.else
+BDREL= 5
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+ONLY_FOR_ARCHS= i386
+RESTRICTED= "License prohibits redistribution"
+
+do-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ @${ECHO} ""
+ @${ECHO} "You have to fetch ${DISTNAME}${EXTRACT_SUFX} manually after"
+ @${ECHO} "reading and agreeing to the license at:"
+ @${ECHO} ""
+ @${ECHO} "ftp://ftp.bitdefender.com/pub/freebsd/${BDREL}/beta/LICENSE"
+ @${ECHO} ""
+ @${ECHO} "A direct link to the distribution file:"
+ @${ECHO} "ftp://ftp.bitdefender.com/pub/freebsd/${BDREL}/beta/${DISTNAME}${EXTRACT_SUFX}"
+ @${ECHO} ""
+ @${ECHO} "Once the file has been downloaded move it to"
+ @${ECHO} "${DISTDIR} and restart the build."
+ @${ECHO} ""
+ @${FALSE}
+.endif
+
+do-install:
+ @cd ${WRKDIR} && ${TAR} -cf - bdc | ${TAR} -xf - -C ${PREFIX}/
+ @${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/bdc
+ @${CHMOD} -R a=rX,u+w ${PREFIX}/bdc/
+
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%PORTNAME%%|${PORTNAME}|g' \
+ < ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ < ${FILESDIR}/bdc > ${PREFIX}/bin/bdc
+ @${CHMOD} +x ${PREFIX}/bin/bdc
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>