aboutsummaryrefslogtreecommitdiff
path: root/security/bdc
diff options
context:
space:
mode:
authorNiels Heinen <niels@FreeBSD.org>2005-06-05 13:36:22 +0000
committerNiels Heinen <niels@FreeBSD.org>2005-06-05 13:36:22 +0000
commit64101141a14c401cdfb68bd4afec68dbc7e01d2b (patch)
treeecfcb050768a1173b65613ebb270c42da3d0af6d /security/bdc
parentdd8a978938895ca47f7441835bfebcde75664c8a (diff)
downloadports-64101141a14c401cdfb68bd4afec68dbc7e01d2b.tar.gz
ports-64101141a14c401cdfb68bd4afec68dbc7e01d2b.zip
Notes
Diffstat (limited to 'security/bdc')
-rw-r--r--security/bdc/Makefile66
-rw-r--r--security/bdc/distinfo4
-rw-r--r--security/bdc/files/bdc4
-rw-r--r--security/bdc/pkg-descr3
-rw-r--r--security/bdc/pkg-message16
-rw-r--r--security/bdc/pkg-plist105
6 files changed, 198 insertions, 0 deletions
diff --git a/security/bdc/Makefile b/security/bdc/Makefile
new file mode 100644
index 000000000000..8d072c5c80a4
--- /dev/null
+++ b/security/bdc/Makefile
@@ -0,0 +1,66 @@
+# New ports collection makefile for: bdc
+# Date created: 4 December 2004
+# Whom: Adi Pircalabu <apircalabu@bitdefender.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bdc
+PORTVERSION= 7.0.1
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.bitdefender.com/pub/freebsd/${BDREL}/beta/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-fbsd${BDREL}
+
+MAINTAINER= apircalabu@bitdefender.com
+COMMENT= BitDefender Console Antivirus for FreeBSD
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 490000 || ${OSVERSION} >= 500000 && ${OSVERSION} < 502001
+IGNORE= "requires FreeBSD-STABLE \(4.9 or later\), or FreeBSD-CURRENT \(5.2.1 or later\)"
+.elif ${OSVERSION} < 500000
+BDREL= 4
+.else
+BDREL= 5
+.endif
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+ONLY_FOR_ARCHS= i386
+RESTRICTED= "License prohibits redistribution"
+
+do-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ @${ECHO} ""
+ @${ECHO} "You have to fetch ${DISTNAME}${EXTRACT_SUFX} manually after"
+ @${ECHO} "reading and agreeing to the license at:"
+ @${ECHO} ""
+ @${ECHO} "ftp://ftp.bitdefender.com/pub/freebsd/${BDREL}/beta/LICENSE"
+ @${ECHO} ""
+ @${ECHO} "A direct link to the distribution file:"
+ @${ECHO} "ftp://ftp.bitdefender.com/pub/freebsd/${BDREL}/beta/${DISTNAME}${EXTRACT_SUFX}"
+ @${ECHO} ""
+ @${ECHO} "Once the file has been downloaded move it to"
+ @${ECHO} "${DISTDIR} and restart the build."
+ @${ECHO} ""
+ @${FALSE}
+.endif
+
+do-install:
+ @cd ${WRKDIR} && ${TAR} -cf - bdc | ${TAR} -xf - -C ${PREFIX}/
+ @${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/bdc
+ @${CHMOD} -R a=rX,u+w ${PREFIX}/bdc/
+
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; \
+ s|%%PORTNAME%%|${PORTNAME}|g' \
+ < ${PKGDIR}/pkg-message > ${PKGMESSAGE}
+
+ @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ < ${FILESDIR}/bdc > ${PREFIX}/bin/bdc
+ @${CHMOD} +x ${PREFIX}/bin/bdc
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/security/bdc/distinfo b/security/bdc/distinfo
new file mode 100644
index 000000000000..15abce56faa8
--- /dev/null
+++ b/security/bdc/distinfo
@@ -0,0 +1,4 @@
+MD5 (bdc-7.0.1-fbsd4.tar.gz) = efe808f78bd4f14dc3052ee525b0912e
+SIZE (bdc-7.0.1-fbsd4.tar.gz) = 3300178
+MD5 (bdc-7.0.1-fbsd5.tar.gz) = dc771133ca4d326df2dc4ed74687b430
+SIZE (bdc-7.0.1-fbsd5.tar.gz) = 3273343
diff --git a/security/bdc/files/bdc b/security/bdc/files/bdc
new file mode 100644
index 000000000000..c56c10d2a76c
--- /dev/null
+++ b/security/bdc/files/bdc
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+BDENG_PATH=%%PREFIX%%/bdc/; export BDENG_PATH
+exec %%PREFIX%%/bdc/bdc.bin ${@+"$@"}
diff --git a/security/bdc/pkg-descr b/security/bdc/pkg-descr
new file mode 100644
index 000000000000..16e8b6324778
--- /dev/null
+++ b/security/bdc/pkg-descr
@@ -0,0 +1,3 @@
+BitDefender Console Antivirus
+
+WWW: http://www.bitdefender.com/
diff --git a/security/bdc/pkg-message b/security/bdc/pkg-message
new file mode 100644
index 000000000000..b4b4aa415d4d
--- /dev/null
+++ b/security/bdc/pkg-message
@@ -0,0 +1,16 @@
+
+Congratulations, BitDefender Console Antivirus for FreeBSD is now installed.
+For your reference, the License Agreement is located in:
+%%PREFIX%%/%%PORTNAME%%/doc/LICENSE
+
+For more info on BitDefender Console Antivirus, you should check the
+documentation located in:
+%%PREFIX%%/%%PORTNAME%%/doc
+
+You should also update the virus definitions as soon as possible by running:
+
+%%PORTNAME%% --update
+
+The BitDefender Team,
+http://www.bitdefender.com
+
diff --git a/security/bdc/pkg-plist b/security/bdc/pkg-plist
new file mode 100644
index 000000000000..d332f50fdcdd
--- /dev/null
+++ b/security/bdc/pkg-plist
@@ -0,0 +1,105 @@
+bdc/Plugins/ace.xmd
+bdc/Plugins/alz.xmd
+bdc/Plugins/arc.xmd
+bdc/Plugins/arj.xmd
+bdc/Plugins/bach.xmd
+bdc/Plugins/bzip2.xmd
+bdc/Plugins/cab.xmd
+bdc/Plugins/ceva_dll.cvd
+bdc/Plugins/ceva_vfs.cvd
+bdc/Plugins/cevakrnl.cvd
+bdc/Plugins/cevakrnl.ivd
+bdc/Plugins/cevakrnl.rvd
+bdc/Plugins/cevakrnl.xmd
+bdc/Plugins/chm.xmd
+bdc/Plugins/cpio.xmd
+bdc/Plugins/cran.cvd
+bdc/Plugins/cran.xmd
+bdc/Plugins/dbx.xmd
+bdc/Plugins/docfile.xmd
+bdc/Plugins/emalware.cvd
+bdc/Plugins/emalware.ivd
+bdc/Plugins/emalware.xmd
+bdc/Plugins/epoc.xmd
+bdc/Plugins/gzip.xmd
+bdc/Plugins/ha.xmd
+bdc/Plugins/hlp.xmd
+bdc/Plugins/hpe.cvd
+bdc/Plugins/hpe.xmd
+bdc/Plugins/hqx.xmd
+bdc/Plugins/html.xmd
+bdc/Plugins/imp.xmd
+bdc/Plugins/inno.xmd
+bdc/Plugins/instyler.xmd
+bdc/Plugins/iso.xmd
+bdc/Plugins/java.cvd
+bdc/Plugins/java.xmd
+bdc/Plugins/jpeg.xmd
+bdc/Plugins/lha.xmd
+bdc/Plugins/lnk.xmd
+bdc/Plugins/mbox.xmd
+bdc/Plugins/mbx.xmd
+bdc/Plugins/mdx.xmd
+bdc/Plugins/mdx_97.cvd
+bdc/Plugins/mdx_97.ivd
+bdc/Plugins/mdx_w95.cvd
+bdc/Plugins/mdx_x95.cvd
+bdc/Plugins/mdx_xf.cvd
+bdc/Plugins/mime.xmd
+bdc/Plugins/mso.xmd
+bdc/Plugins/na.cvd
+bdc/Plugins/na.xmd
+bdc/Plugins/nelf.cvd
+bdc/Plugins/nelf.xmd
+bdc/Plugins/nsis.xmd
+bdc/Plugins/objd.xmd
+bdc/Plugins/pdf.xmd
+bdc/Plugins/pst.xmd
+bdc/Plugins/rar.xmd
+bdc/Plugins/rpm.xmd
+bdc/Plugins/rtf.xmd
+bdc/Plugins/rup.cvd
+bdc/Plugins/rup.xmd
+bdc/Plugins/sdx.cvd
+bdc/Plugins/sdx.ivd
+bdc/Plugins/sdx.xmd
+bdc/Plugins/sfx.xmd
+bdc/Plugins/swf.xmd
+bdc/Plugins/tar.xmd
+bdc/Plugins/td0.xmd
+bdc/Plugins/thebat.xmd
+bdc/Plugins/tnef.xmd
+bdc/Plugins/unpack.cvd
+bdc/Plugins/unpack.ivd
+bdc/Plugins/unpack.xmd
+bdc/Plugins/update.txt
+bdc/Plugins/uudecode.xmd
+bdc/Plugins/ve.cvd
+bdc/Plugins/ve.ivd
+bdc/Plugins/ve.xmd
+bdc/Plugins/vedata.cvd
+bdc/Plugins/viza.xmd
+bdc/Plugins/wise.xmd
+bdc/Plugins/xishield.xmd
+bdc/Plugins/z.xmd
+bdc/Plugins/zip.xmd
+bdc/Plugins/zoo.xmd
+bdc/bdc
+bdc/bdc.bin
+bdc/bdc.ini
+bdc/bdcore.so
+bdc/bdupd.so
+bdc/doc/FAQ
+bdc/doc/INSTALL
+bdc/doc/KNOWN-ISSUES
+bdc/doc/LICENSE
+bdc/doc/README
+bdc/libfn.so
+bdc/man/bdc.1
+bdc/plugins.htm
+bin/bdc
+@dirrm bdc/Plugins
+@dirrm bdc/doc
+@dirrm bdc/man
+@dirrm bdc
+@unexec rmdir %D/bdc 2>/dev/null || echo "If you are permanently removing this port, you should do a \"rm -rf %D/bdc\" to remove files installed after doing an update. " | fmt