aboutsummaryrefslogtreecommitdiff
path: root/security/bjorb
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-13 15:09:38 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-13 15:09:38 +0000
commitf041fcbfe05d07c818cdbf3b295bdec4e684e22b (patch)
tree24cd6bbd8bdca44c6e8eb0d1968d22fa1993b125 /security/bjorb
parentcb3da2cc269c249f4cba259aee1f7b37733c9e6d (diff)
downloadports-f041fcbfe05d07c818cdbf3b295bdec4e684e22b.tar.gz
ports-f041fcbfe05d07c818cdbf3b295bdec4e684e22b.zip
Notes
Diffstat (limited to 'security/bjorb')
-rw-r--r--security/bjorb/Makefile4
-rw-r--r--security/bjorb/files/patch-aa27
-rw-r--r--security/bjorb/files/patch-ad22
-rw-r--r--security/bjorb/files/patch-ae14
-rw-r--r--security/bjorb/files/patch-af14
-rw-r--r--security/bjorb/files/patch-ag12
-rw-r--r--security/bjorb/files/patch-ah14
7 files changed, 100 insertions, 7 deletions
diff --git a/security/bjorb/Makefile b/security/bjorb/Makefile
index 3cc8386968b8..5176e9e18729 100644
--- a/security/bjorb/Makefile
+++ b/security/bjorb/Makefile
@@ -39,10 +39,6 @@ EXAMPLES= doc/sample/bjorb.conf.doc
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500035
-BROKEN= "Does not compile on 5.0"
-.endif
-
post-install:
@${INSTALL_SCRIPT} ${DOCSRC}/doc/sample/bjorb.sh ${PREFIX}/etc/rc.d/bjorb.sh.sample
.if !defined(NOPORTDOCS)
diff --git a/security/bjorb/files/patch-aa b/security/bjorb/files/patch-aa
index 3219c68c2db0..0f8c5eb490f9 100644
--- a/security/bjorb/files/patch-aa
+++ b/security/bjorb/files/patch-aa
@@ -1,5 +1,5 @@
--- Makefile.in.orig Mon Feb 22 05:01:20 1999
-+++ Makefile.in Wed Mar 24 20:52:03 1999
++++ Makefile.in Sun Jan 12 14:46:10 2003
@@ -29,7 +29,7 @@
LDFLAGS =
LIBS = @LIBS@
@@ -9,6 +9,31 @@
exec_prefix = $(PREFIX)
sbindir = $(exec_prefix)/sbin
etcdir = $(exec_prefix)/etc
+@@ -81,7 +81,7 @@
+ $(INSTALL_DATA) ../doc/sample/bjorb.conf.sample $(etcdir)/bjorb.conf.sample
+
+ $(TARGET): $(OBJS)
+- $(CC) -o $(TARGET) $(ALL_LDFLAGS) $(OBJS) $(ALL_LIBS)
++ $(CXX) -o $(TARGET) $(ALL_LDFLAGS) $(OBJS) $(ALL_LIBS)
+
+ debug::
+ $(MAKE) CFLAGS="-g -DDEBUG"
+@@ -116,13 +116,13 @@
+ $(CC) -c $(ALL_CFLAGS) $<
+
+ .cc.o: Makefile
+- $(CC) -c $(ALL_CFLAGS) $<
++ $(CXX) -c $(ALL_CFLAGS) $<
+
+ Makefile: Makefile.in
+ CONFIG_FILES=./$@ CONFIG_HEADERS= $(SHELL) ./config.status
+
+ cmd.o: cmd.cc cmd-def.h
+- $(CC) -c $(ALL_CFLAGS) $<
++ $(CXX) -c $(ALL_CFLAGS) $<
+ cmd.cc: cmd.list
+ gperf -aptCT -N in_word_set_cmdlist $? > $@
+ bool.cc:bool.list
@@ -135,9 +135,13 @@
autoconf
diff --git a/security/bjorb/files/patch-ad b/security/bjorb/files/patch-ad
index 9275b45a429a..0b2209425b9f 100644
--- a/security/bjorb/files/patch-ad
+++ b/security/bjorb/files/patch-ad
@@ -1,5 +1,5 @@
---- Config.cc.orig Sun Dec 26 11:25:39 1999
-+++ Config.cc Sun Dec 26 11:25:57 1999
+--- Config.cc.orig Mon Feb 22 04:07:51 1999
++++ Config.cc Sun Jan 12 14:34:28 2003
@@ -334,7 +334,7 @@
int retval = 1;
@@ -9,3 +9,21 @@
#ifndef NO_DEBUG
PUTERR(2, ("::accept() begin\n"));
+@@ -574,7 +574,7 @@
+ if (accept_port.getPortinfo()->isVerify()) {
+ _SSL_set_verify(ssl,
+ SSL_VERIFY_PEER|SSL_VERIFY_FAIL_IF_NO_PEER_CERT,
+- (int (*)(...))BjorbSSLVerifyCallback);
++ BjorbSSLVerifyCallback);
+ } else {
+ _SSL_set_verify(ssl, SSL_VERIFY_NONE, 0);
+ }
+@@ -620,7 +620,7 @@
+ } else {
+ _SSL_CTX_set_verify(ctx_connect,
+ SSL_VERIFY_PEER|SSL_VERIFY_FAIL_IF_NO_PEER_CERT,
+- (int (*)(...))BjorbSSLVerifyCallback);
++ BjorbSSLVerifyCallback);
+ }
+
+ ssl = _SSL_new(ctx_connect);
diff --git a/security/bjorb/files/patch-ae b/security/bjorb/files/patch-ae
new file mode 100644
index 000000000000..15ea1c500bc1
--- /dev/null
+++ b/security/bjorb/files/patch-ae
@@ -0,0 +1,14 @@
+--- bool.cc.orig Mon Feb 22 03:40:47 1999
++++ bool.cc Sun Jan 12 14:42:05 2003
+@@ -1,6 +1,11 @@
+ /* C code produced by gperf version 2.1 (K&R C version) */
+ /* Command-line: gperf -aptCT -N in_word_set_boollist bool.list */
+
++#include "config.h"
++
++#ifdef HAVE_STRING_H
++#include <string.h>
++#endif /* HAVE_STRING_H */
+
+ #include "common.h"
+ #include "bool.h"
diff --git a/security/bjorb/files/patch-af b/security/bjorb/files/patch-af
new file mode 100644
index 000000000000..68ea9f4477a1
--- /dev/null
+++ b/security/bjorb/files/patch-af
@@ -0,0 +1,14 @@
+--- cmd.cc.orig Mon Feb 22 03:40:47 1999
++++ cmd.cc Sun Jan 12 14:40:41 2003
+@@ -3,6 +3,11 @@
+
+
+ #include "config.h"
++
++#ifdef HAVE_STRING_H
++#include <string.h>
++#endif /* HAVE_STRING_H */
++
+ #include "cmd.h"
+ #include "Config.h"
+ #include "cmd-def.h"
diff --git a/security/bjorb/files/patch-ag b/security/bjorb/files/patch-ag
new file mode 100644
index 000000000000..a1b08e8cf073
--- /dev/null
+++ b/security/bjorb/files/patch-ag
@@ -0,0 +1,12 @@
+--- portinfo.cc.orig Mon Feb 22 03:40:47 1999
++++ portinfo.cc Sun Jan 12 14:40:05 2003
+@@ -1,3 +1,9 @@
++#include "config.h"
++
++#ifdef HAVE_STRING_H
++#include <string.h>
++#endif /* HAVE_STRING_H */
++
+ #include "common.h"
+ #include "portinfo.h"
+ #include "token.h"
diff --git a/security/bjorb/files/patch-ah b/security/bjorb/files/patch-ah
new file mode 100644
index 000000000000..5fb500abdc0c
--- /dev/null
+++ b/security/bjorb/files/patch-ah
@@ -0,0 +1,14 @@
+--- portoption.cc.orig Mon Feb 22 03:40:47 1999
++++ portoption.cc Sun Jan 12 14:41:00 2003
+@@ -3,6 +3,11 @@
+
+
+ #include "config.h"
++
++#ifdef HAVE_STRING_H
++#include <string.h>
++#endif /* HAVE_STRING_H */
++
+ #include "Config.h"
+
+ #define MIN_WORD_LENGTH 3