aboutsummaryrefslogtreecommitdiff
path: root/security/boringssl
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2017-06-29 15:51:01 +0000
committerSteve Wills <swills@FreeBSD.org>2017-06-29 15:51:01 +0000
commit801f06b11e5dc241a6bb24972c108aa24cea9ce6 (patch)
treed414e55f2cbe90a81c0be59ff0c30a65d9720861 /security/boringssl
parenta85b06a12be387c5f474aae1d97ecf80e7256c2f (diff)
downloadports-801f06b11e5dc241a6bb24972c108aa24cea9ce6.tar.gz
ports-801f06b11e5dc241a6bb24972c108aa24cea9ce6.zip
security/boringssl: create port
Fork of OpenSSL that is designed to meet Google's needs WWW: https://github.com/google/boringssl
Notes
Notes: svn path=/head/; revision=444652
Diffstat (limited to 'security/boringssl')
-rw-r--r--security/boringssl/Makefile33
-rw-r--r--security/boringssl/distinfo3
-rw-r--r--security/boringssl/files/patch-crypto_bio_bio__test.cc13
-rw-r--r--security/boringssl/files/patch-crypto_lhash_lhash__test.cc13
-rw-r--r--security/boringssl/pkg-descr3
-rw-r--r--security/boringssl/pkg-plist79
-rw-r--r--security/boringssl/version.mk1
7 files changed, 145 insertions, 0 deletions
diff --git a/security/boringssl/Makefile b/security/boringssl/Makefile
new file mode 100644
index 000000000000..0b2400f1bb30
--- /dev/null
+++ b/security/boringssl/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= boringssl
+PORTVERSION= 0.0.0.0.2017.06.28.01
+CATEGORIES= security
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Fork of OpenSSL
+
+BUILD_DEPENDS= go:lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= google
+GH_TAGNAME= 3c97292
+USES= cmake localbase perl5
+CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS=1
+USE_LDCONFIG= yes
+LDFLAGS+= -Wl,-rpath,${PREFIX}/lib
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tool/bssl ${STAGEDIR}${PREFIX}/bin/
+ (cd ${WRKSRC}/include && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/include)
+ ${INSTALL_LIB} ${WRKSRC}/crypto/libcrypto.so ${STAGEDIR}${PREFIX}/lib/libcrypto.so.1.0.0
+ ${INSTALL_LIB} ${WRKSRC}/ssl/libssl.so ${STAGEDIR}${PREFIX}/lib/libssl.so.1.0.0
+ ${LN} -sf libcrypto.so.1 ${STAGEDIR}${PREFIX}/lib/libcrypto.so
+ ${LN} -sf libcrypto.so.1.0.0 ${STAGEDIR}${PREFIX}/lib/libcrypto.so.1
+ ${LN} -sf libssl.so.1 ${STAGEDIR}${PREFIX}/lib/libssl.so
+ ${LN} -sf libssl.so.1.0.0 ${STAGEDIR}${PREFIX}/lib/libssl.so.1
+
+test: build
+ cd ${WRKSRC} ; ${MAKE_CMD} run_tests
+
+.include <bsd.port.mk>
diff --git a/security/boringssl/distinfo b/security/boringssl/distinfo
new file mode 100644
index 000000000000..d2dac0f8e913
--- /dev/null
+++ b/security/boringssl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1498679351
+SHA256 (google-boringssl-0.0.0.0.2017.06.28.01-3c97292_GH0.tar.gz) = 30df74b1bc32f9e6b34009bb4adc3c97c7cd1379ebd291f850dcee35d9b31cf6
+SIZE (google-boringssl-0.0.0.0.2017.06.28.01-3c97292_GH0.tar.gz) = 12809805
diff --git a/security/boringssl/files/patch-crypto_bio_bio__test.cc b/security/boringssl/files/patch-crypto_bio_bio__test.cc
new file mode 100644
index 000000000000..0afd37b0378c
--- /dev/null
+++ b/security/boringssl/files/patch-crypto_bio_bio__test.cc
@@ -0,0 +1,13 @@
+--- crypto/bio/bio_test.cc.orig 2017-06-28 13:35:29 UTC
++++ crypto/bio/bio_test.cc
+@@ -12,10 +12,6 @@
+ * OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+ * CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. */
+
+-#if !defined(_POSIX_C_SOURCE)
+-#define _POSIX_C_SOURCE 201410L
+-#endif
+-
+ #include <algorithm>
+ #include <string>
+
diff --git a/security/boringssl/files/patch-crypto_lhash_lhash__test.cc b/security/boringssl/files/patch-crypto_lhash_lhash__test.cc
new file mode 100644
index 000000000000..e2c630773856
--- /dev/null
+++ b/security/boringssl/files/patch-crypto_lhash_lhash__test.cc
@@ -0,0 +1,13 @@
+--- crypto/lhash/lhash_test.cc.orig 2017-06-28 13:35:29 UTC
++++ crypto/lhash/lhash_test.cc
+@@ -12,10 +12,6 @@
+ * OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+ * CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. */
+
+-#if !defined(_POSIX_C_SOURCE)
+-#define _POSIX_C_SOURCE 201410L
+-#endif
+-
+ #include <openssl/lhash.h>
+
+ #include <stdio.h>
diff --git a/security/boringssl/pkg-descr b/security/boringssl/pkg-descr
new file mode 100644
index 000000000000..bedda8059398
--- /dev/null
+++ b/security/boringssl/pkg-descr
@@ -0,0 +1,3 @@
+Fork of OpenSSL that is designed to meet Google's needs
+
+WWW: https://github.com/google/boringssl
diff --git a/security/boringssl/pkg-plist b/security/boringssl/pkg-plist
new file mode 100644
index 000000000000..edc545d68119
--- /dev/null
+++ b/security/boringssl/pkg-plist
@@ -0,0 +1,79 @@
+bin/bssl
+include/openssl/aead.h
+include/openssl/aes.h
+include/openssl/arm_arch.h
+include/openssl/asn1.h
+include/openssl/asn1_mac.h
+include/openssl/asn1t.h
+include/openssl/base.h
+include/openssl/base64.h
+include/openssl/bio.h
+include/openssl/blowfish.h
+include/openssl/bn.h
+include/openssl/buf.h
+include/openssl/buffer.h
+include/openssl/bytestring.h
+include/openssl/cast.h
+include/openssl/chacha.h
+include/openssl/cipher.h
+include/openssl/cmac.h
+include/openssl/conf.h
+include/openssl/cpu.h
+include/openssl/crypto.h
+include/openssl/curve25519.h
+include/openssl/des.h
+include/openssl/dh.h
+include/openssl/digest.h
+include/openssl/dsa.h
+include/openssl/dtls1.h
+include/openssl/ec.h
+include/openssl/ec_key.h
+include/openssl/ecdh.h
+include/openssl/ecdsa.h
+include/openssl/engine.h
+include/openssl/err.h
+include/openssl/evp.h
+include/openssl/ex_data.h
+include/openssl/hkdf.h
+include/openssl/hmac.h
+include/openssl/is_boringssl.h
+include/openssl/lhash.h
+include/openssl/lhash_macros.h
+include/openssl/md4.h
+include/openssl/md5.h
+include/openssl/mem.h
+include/openssl/nid.h
+include/openssl/obj.h
+include/openssl/obj_mac.h
+include/openssl/objects.h
+include/openssl/opensslconf.h
+include/openssl/opensslv.h
+include/openssl/ossl_typ.h
+include/openssl/pem.h
+include/openssl/pkcs12.h
+include/openssl/pkcs7.h
+include/openssl/pkcs8.h
+include/openssl/poly1305.h
+include/openssl/pool.h
+include/openssl/rand.h
+include/openssl/rc4.h
+include/openssl/ripemd.h
+include/openssl/rsa.h
+include/openssl/safestack.h
+include/openssl/sha.h
+include/openssl/srtp.h
+include/openssl/ssl.h
+include/openssl/ssl3.h
+include/openssl/stack.h
+include/openssl/thread.h
+include/openssl/tls1.h
+include/openssl/type_check.h
+include/openssl/x509.h
+include/openssl/x509_vfy.h
+include/openssl/x509v3.h
+lib/libcrypto.so
+lib/libcrypto.so.1
+lib/libcrypto.so.1.0.0
+lib/libssl.so
+lib/libssl.so.1
+lib/libssl.so.1.0.0
diff --git a/security/boringssl/version.mk b/security/boringssl/version.mk
new file mode 100644
index 000000000000..63e31f5bffa0
--- /dev/null
+++ b/security/boringssl/version.mk
@@ -0,0 +1 @@
+OPENSSL_SHLIBVER?= 1