aboutsummaryrefslogtreecommitdiff
path: root/security/botan/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-02-17 07:43:43 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-02-17 07:43:43 +0000
commit87ddd82202d35c20d7bc3c781cb6c250472acd4a (patch)
tree50244cd05f071791efba77c6d4f3a91ced34d1f8 /security/botan/Makefile
parent51f07782e008acf30930d16d4b32fee9888a09cc (diff)
Notes
Diffstat (limited to 'security/botan/Makefile')
-rw-r--r--security/botan/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/security/botan/Makefile b/security/botan/Makefile
index 5a5afb462ad9..8df8361807b6 100644
--- a/security/botan/Makefile
+++ b/security/botan/Makefile
@@ -7,20 +7,21 @@
#
PORTNAME= botan
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.4
PORTREVISION= 0
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/files/
DISTNAME= Botan-${PORTVERSION}
-EXTRACT_SUFX= .tgz
+EXTRACT_SUFX= .tbz
MAINTAINER= clsung@FreeBSD.org
COMMENT= A portable, easy to use, and efficient C++ crypto library
+USE_BZIP2= yes
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.pl
-CONFIGURE_ARGS= gcc-freebsd-generic
+CONFIGURE_ARGS= --prefix=${PREFIX} gcc-freebsd-generic
USE_GMAKE= yes
MAKE_ARGS= CXX="${CXX}" LIB_OPT="${CXXFLAGS}" \
LANG_FLAGS="-fpermissive"
@@ -28,13 +29,21 @@ INSTALLS_SHLIB= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/Botan-${PORTVERSION}
+PORTDOCS= *
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500035
CONFIGURE_ARGS+= --noauto
PLIST_SUB+= OS_4="@comment "
.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include::mem_pool.h-gcc295
PLIST_SUB+= OS_4=""
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
.endif
.if ${PERL_LEVEL} < 500601