aboutsummaryrefslogtreecommitdiff
path: root/security/botan110
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2013-05-22 18:07:53 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2013-05-22 18:07:53 +0000
commit6dfcd07f9a393e545c14cf560b9dcca62793f47e (patch)
treee1ca0013feb2160f567d18eab83cfce5945da177 /security/botan110
parent62ebfa21d77da0c53b1f27ee37691b87abbefb13 (diff)
downloadports-6dfcd07f9a393e545c14cf560b9dcca62793f47e.tar.gz
ports-6dfcd07f9a393e545c14cf560b9dcca62793f47e.zip
Copy botan port to new port for botan 1.10 which can coexist with
the old port. PR: ports/178812 Submitted by: Lapo Luchini <lapo@lapo.it> (maintainer of security/botan)
Notes
Notes: svn path=/head/; revision=318782
Diffstat (limited to 'security/botan110')
-rw-r--r--security/botan110/Makefile73
-rw-r--r--security/botan110/distinfo2
-rw-r--r--security/botan110/files/patch-src_build_data_makefile_unix_shr.in11
-rw-r--r--security/botan110/pkg-descr14
4 files changed, 100 insertions, 0 deletions
diff --git a/security/botan110/Makefile b/security/botan110/Makefile
new file mode 100644
index 000000000000..d98dacb08698
--- /dev/null
+++ b/security/botan110/Makefile
@@ -0,0 +1,73 @@
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= botan
+PORTVERSION= 1.10.5
+CATEGORIES= security
+MASTER_SITES= http://files.randombit.net/botan/v1.10/
+PKGNAMESUFFIX= 110
+DISTNAME= Botan-${PORTVERSION}
+EXTRACT_SUFX= .tbz
+
+MAINTAINER= lapo@lapo.it
+COMMENT= Portable, easy to use, and efficient C++ crypto library
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/doc/license.txt
+
+LATEST_LINK= botan${PKGNAMESUFFIX}
+
+OPTIONS_DEFINE= SSL GMP ECC
+OPTIONS_DEFAULT= SSL GMP ECC
+ECC_DESC= ECC support
+
+USE_BZIP2= yes
+USE_PYTHON_BUILD= yes
+HAS_CONFIGURE= yes
+CONFIGURE_SCRIPT= configure.py
+CONFIGURE_ARGS= --prefix=${PREFIX} --with-tr1-implementation=boost \
+ --with-bzip2 --with-zlib
+USE_GMAKE= yes
+MAKE_ARGS= CXX="${CXX}" LIB_OPT="${CXXFLAGS}"
+USE_LDCONFIG= yes
+PLIST_FILES= bin/botan-config-1.10 lib/libbotan-1.10.a lib/libbotan-1.10.so lib/libbotan-1.10.so.0 \
+ lib/libbotan-1.10.so.0.5 libdata/pkgconfig/botan-1.10.pc
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
+PORTDOCS= *
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSSL}
+USE_OPENSSL= yes
+CONFIGURE_ARGS+=--with-openssl
+.endif
+
+.if ${PORT_OPTIONS:MGMP}
+LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
+CONFIGURE_ARGS+=--with-gnump
+MAKE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
+.endif
+
+.if ${PORT_OPTIONS:MECC}
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/tr1/memory.hpp:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS+=--with-tr1-implementation=boost
+CXXFLAGS+= -I${LOCALBASE}/include
+.else
+CONFIGURE_ARGS+=--with-tr1-implementation=none
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|#!/usr/bin/env python|#!${PYTHON_CMD}|" \
+ ${WRKSRC}/configure.py
+.if ! ${PORT_OPTIONS:MDOCS}
+ ${REINPLACE_CMD} -e '/DOCDIR/d' \
+ ${WRKSRC}/src/build-data/makefile/unix_shr.in
+.endif
+
+post-install:
+ @(cd ${PREFIX}; ${FIND} -s include/botan-1.10 -not -type d) >> ${TMPPLIST}
+ @${ECHO_CMD} @dirrm include/botan-1.10/botan >> ${TMPPLIST}
+ @${ECHO_CMD} @dirrm include/botan-1.10 >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/security/botan110/distinfo b/security/botan110/distinfo
new file mode 100644
index 000000000000..adf38c9e1288
--- /dev/null
+++ b/security/botan110/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Botan-1.10.5.tbz) = 2934c00533847dc93c485081d3ce6aae4a110151a69b587b895241159da77cf3
+SIZE (Botan-1.10.5.tbz) = 2214817
diff --git a/security/botan110/files/patch-src_build_data_makefile_unix_shr.in b/security/botan110/files/patch-src_build_data_makefile_unix_shr.in
new file mode 100644
index 000000000000..109060afa1bd
--- /dev/null
+++ b/security/botan110/files/patch-src_build_data_makefile_unix_shr.in
@@ -0,0 +1,11 @@
+--- src/build-data/makefile/unix_shr.in.orig 2011-09-02 19:36:47.671575619 +0000
++++ src/build-data/makefile/unix_shr.in 2011-09-02 19:37:32.341486166 +0000
+@@ -20,7 +20,7 @@
+ LIBDIR = $(DESTDIR)/%{libdir}
+ HEADERDIR = $(DESTDIR)/%{includedir}/botan-$(SERIES)/botan
+ DOCDIR = $(DESTDIR)/%{docdir}/botan-$(VERSION)
+-PKGCONF_DIR = $(LIBDIR)/pkgconfig
++PKGCONF_DIR = $(DESTDIR)/libdata/pkgconfig
+
+ CONFIG_SCRIPT = %{botan_config}
+ PKGCONFIG = %{botan_pkgconfig}
diff --git a/security/botan110/pkg-descr b/security/botan110/pkg-descr
new file mode 100644
index 000000000000..d4436e230a7a
--- /dev/null
+++ b/security/botan110/pkg-descr
@@ -0,0 +1,14 @@
+Botan is a crypto library written in C++. It provides a variety of
+cryptographic algorithms, including common ones such as AES, MD5, SHA,
+HMAC, RSA, Diffie-Hellman, DSA, and ECDSA, as well as many others that
+are more obscure or specialized. It also offers X.509v3 certificates
+and CRLs, and PKCS #10 certificate requests. A message processing
+system that uses a filter/pipeline metaphor allows for many common
+cryptographic tasks to be completed with just a few lines of code.
+Assembly optimizations for common CPUs, including x86, x86-64, and
+PowerPC, offers further speedups for critical tasks such as SHA-1
+hashing and multiple precision integer operations.
+
+Botan is licensed under the same permissive terms as FreeBSD itself.
+
+WWW: http://botan.randombit.net/