aboutsummaryrefslogtreecommitdiff
path: root/security/botan2
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-15 14:07:14 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-11-15 14:07:14 +0000
commitc5977c3033f57e94f8d76c13c5c610fc700c529e (patch)
tree6f211a49333dc9079b7032647675ae2003232cda /security/botan2
parentd033b65c360f24fd4fecc6b9970712679b6dfb4e (diff)
downloadports-c5977c3033f57e94f8d76c13c5c610fc700c529e.tar.gz
ports-c5977c3033f57e94f8d76c13c5c610fc700c529e.zip
- Update to 2.17.2
- Fix building in presence of older version of botan2 installed in the system by importing upstream patch PR: 251106 Submitted by: tremere@cainites.net (maintainer) Reported by: amdmi3, acupuncture@cgocable.ca, fastmint@hush.com
Notes
Notes: svn path=/head/; revision=555220
Diffstat (limited to 'security/botan2')
-rw-r--r--security/botan2/Makefile2
-rw-r--r--security/botan2/distinfo6
-rw-r--r--security/botan2/files/patch-fix-link-paths36
3 files changed, 40 insertions, 4 deletions
diff --git a/security/botan2/Makefile b/security/botan2/Makefile
index 5c0f076c4543..74bb8578f847 100644
--- a/security/botan2/Makefile
+++ b/security/botan2/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= botan
-DISTVERSION= 2.17.1
+DISTVERSION= 2.17.2
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/releases/
PKGNAMESUFFIX= 2
diff --git a/security/botan2/distinfo b/security/botan2/distinfo
index 06a6fb8fc199..49919eb6110e 100644
--- a/security/botan2/distinfo
+++ b/security/botan2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604775880
-SHA256 (Botan-2.17.1.tar.xz) = 741358b3f1638ed7d9b2f59b4e344aa46f4966b15958b5434c0ac1580df0c0c1
-SIZE (Botan-2.17.1.tar.xz) = 5970240
+TIMESTAMP = 1605386323
+SHA256 (Botan-2.17.2.tar.xz) = ebe27dfe2b55d7e02bf520e926606c48b76b22facb483256b13ab38e018e1e6c
+SIZE (Botan-2.17.2.tar.xz) = 5940964
diff --git a/security/botan2/files/patch-fix-link-paths b/security/botan2/files/patch-fix-link-paths
new file mode 100644
index 000000000000..4a66ff50d12b
--- /dev/null
+++ b/security/botan2/files/patch-fix-link-paths
@@ -0,0 +1,36 @@
+From 639a5c4515a36bcbadb82145d755005620c535c3 Mon Sep 17 00:00:00 2001
+From: Jack Lloyd <jack@randombit.net>
+Date: Fri, 13 Nov 2020 18:04:09 -0500
+Subject: [PATCH] Fix use of -L flag when combined with --external-libdir
+
+GH #2496
+--- configure.py.orig 2020-11-14 16:39:43 UTC
++++ configure.py
+@@ -2118,9 +2118,9 @@ def create_template_vars(source_paths, build_paths, op
+
+ 'visibility_attribute': cc.gen_visibility_attribute(options),
+
+- 'lib_link_cmd': cc.so_link_command_for(osinfo.basename, options) + ' ' + external_link_cmd(),
+- 'exe_link_cmd': cc.binary_link_command_for(osinfo.basename, options) + ' ' + external_link_cmd(),
+- 'post_link_cmd': '',
++ 'lib_link_cmd': cc.so_link_command_for(osinfo.basename, options),
++ 'exe_link_cmd': cc.binary_link_command_for(osinfo.basename, options),
++ 'external_link_cmd': external_link_cmd(),
+
+ 'ar_command': ar_command(),
+ 'ar_options': options.ar_options or cc.ar_options or osinfo.ar_options,
+ configure.py | 6 +++---
+ src/build-data/makefile.in | 2 +-
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+--- src/build-data/makefile.in.orig 2020-11-07 07:43:35 UTC
++++ src/build-data/makefile.in
+@@ -20,7 +20,7 @@ LDFLAGS = %{ldflags}
+
+ EXE_LINK_CMD = %{exe_link_cmd}
+
+-LIB_LINKS_TO = %{link_to}
++LIB_LINKS_TO = %{external_link_cmd} %{link_to}
+ EXE_LINKS_TO = %{link_to_botan} $(LIB_LINKS_TO)
+
+ BUILD_FLAGS = $(ABI_FLAGS) $(LANG_FLAGS) $(CXXFLAGS) $(WARN_FLAGS)