aboutsummaryrefslogtreecommitdiff
path: root/security/botan
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-02-17 07:43:43 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-02-17 07:43:43 +0000
commit87ddd82202d35c20d7bc3c781cb6c250472acd4a (patch)
tree50244cd05f071791efba77c6d4f3a91ced34d1f8 /security/botan
parent51f07782e008acf30930d16d4b32fee9888a09cc (diff)
downloadports-87ddd82202d35c20d7bc3c781cb6c250472acd4a.tar.gz
ports-87ddd82202d35c20d7bc3c781cb6c250472acd4a.zip
Notes
Diffstat (limited to 'security/botan')
-rw-r--r--security/botan/Makefile15
-rw-r--r--security/botan/distinfo4
-rw-r--r--security/botan/files/extra-patch-include::mem_pool.h-gcc29512
-rw-r--r--security/botan/pkg-plist29
4 files changed, 34 insertions, 26 deletions
diff --git a/security/botan/Makefile b/security/botan/Makefile
index 5a5afb462ad9..8df8361807b6 100644
--- a/security/botan/Makefile
+++ b/security/botan/Makefile
@@ -7,20 +7,21 @@
#
PORTNAME= botan
-PORTVERSION= 1.4.0
+PORTVERSION= 1.4.4
PORTREVISION= 0
CATEGORIES= security
MASTER_SITES= http://botan.randombit.net/files/
DISTNAME= Botan-${PORTVERSION}
-EXTRACT_SUFX= .tgz
+EXTRACT_SUFX= .tbz
MAINTAINER= clsung@FreeBSD.org
COMMENT= A portable, easy to use, and efficient C++ crypto library
+USE_BZIP2= yes
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.pl
-CONFIGURE_ARGS= gcc-freebsd-generic
+CONFIGURE_ARGS= --prefix=${PREFIX} gcc-freebsd-generic
USE_GMAKE= yes
MAKE_ARGS= CXX="${CXX}" LIB_OPT="${CXXFLAGS}" \
LANG_FLAGS="-fpermissive"
@@ -28,13 +29,21 @@ INSTALLS_SHLIB= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/Botan-${PORTVERSION}
+PORTDOCS= *
+.endif
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500035
CONFIGURE_ARGS+= --noauto
PLIST_SUB+= OS_4="@comment "
.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-include::mem_pool.h-gcc295
PLIST_SUB+= OS_4=""
+post-patch:
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
.endif
.if ${PERL_LEVEL} < 500601
diff --git a/security/botan/distinfo b/security/botan/distinfo
index 37065bba8b85..a827109bb540 100644
--- a/security/botan/distinfo
+++ b/security/botan/distinfo
@@ -1,2 +1,2 @@
-MD5 (Botan-1.4.0.tgz) = 3154cdeecd2f65fa221cd9b5848b1fb2
-SIZE (Botan-1.4.0.tgz) = 1403507
+MD5 (Botan-1.4.4.tbz) = 804ed83275876e878e28a279350a3473
+SIZE (Botan-1.4.4.tbz) = 1338781
diff --git a/security/botan/files/extra-patch-include::mem_pool.h-gcc295 b/security/botan/files/extra-patch-include::mem_pool.h-gcc295
new file mode 100644
index 000000000000..3f6079ac42ef
--- /dev/null
+++ b/security/botan/files/extra-patch-include::mem_pool.h-gcc295
@@ -0,0 +1,12 @@
+--- include/mem_pool.h.orig Fri Dec 3 12:38:48 2004
++++ include/mem_pool.h Tue Feb 15 15:09:51 2005
+@@ -63,7 +63,9 @@
+ bool same_buffer(Buffer&, Buffer&) const;
+ void remove_empty_buffers(std::vector<Buffer>&) const;
+
++ public:
+ static bool buffer_cmp(const Buffer&, const Buffer&);
++ private:
+ static bool is_empty_buffer(const Buffer&);
+
+ const u32bit PREF_SIZE, ALIGN_TO;
diff --git a/security/botan/pkg-plist b/security/botan/pkg-plist
index ea1c1b846137..567eb7e14b5f 100644
--- a/security/botan/pkg-plist
+++ b/security/botan/pkg-plist
@@ -2,6 +2,7 @@
bin/botan-config
include/botan/adler32.h
include/botan/aes.h
+include/botan/algolist.h
include/botan/allocate.h
include/botan/arc4.h
include/botan/asn1.h
@@ -9,6 +10,7 @@ include/botan/asn1_obj.h
include/botan/asn1_oid.h
include/botan/barrett.h
include/botan/base.h
+include/botan/base_eng.h
include/botan/base64.h
include/botan/basefilt.h
include/botan/ber_dec.h
@@ -23,6 +25,7 @@ include/botan/cast256.h
include/botan/cbc.h
include/botan/certstor.h
include/botan/cfb.h
+include/botan/charset.h
include/botan/conf.h
include/botan/config.h
include/botan/crc24.h
@@ -32,6 +35,7 @@ include/botan/ctr.h
include/botan/cts.h
include/botan/data_snk.h
include/botan/data_src.h
+include/botan/def_eng.h
include/botan/defalloc.h
include/botan/der_enc.h
include/botan/des.h
@@ -45,7 +49,6 @@ include/botan/ecb.h
include/botan/elgamal.h
include/botan/eme.h
include/botan/emsa.h
-include/botan/eng_def.h
include/botan/engine.h
include/botan/enums.h
%%OS_4%%include/botan/es_egd.h
@@ -60,6 +63,7 @@ include/botan/fips140.h
include/botan/fips_rng.h
include/botan/gost.h
include/botan/has160.h
+include/botan/hash_id.h
include/botan/haval.h
include/botan/hex.h
include/botan/hmac.h
@@ -79,6 +83,7 @@ include/botan/md4.h
include/botan/md5.h
include/botan/mdx_hash.h
include/botan/mem_ops.h
+include/botan/mem_pool.h
include/botan/mgf1.h
include/botan/misty1.h
%%OS_4%%include/botan/mmap_mem.h
@@ -133,13 +138,13 @@ include/botan/sha160.h
include/botan/sha256.h
include/botan/sha_64.h
include/botan/skipjack.h
+include/botan/socket.h
include/botan/square.h
include/botan/ssl3_mac.h
include/botan/symkey.h
include/botan/tea.h
include/botan/tiger.h
include/botan/timers.h
-%%OS_4%%include/botan/tm_posix.h
%%OS_4%%include/botan/tm_unix.h
include/botan/twofish.h
include/botan/types.h
@@ -159,27 +164,9 @@ include/botan/x509stor.h
include/botan/x917_rng.h
include/botan/x919_mac.h
include/botan/xtea.h
-lib/libbotan-1.4.0.so
+lib/libbotan-1.4.4.so
lib/libbotan-1.4.so
lib/libbotan-1.so
lib/libbotan.a
lib/libbotan.so
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/api.pdf
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/api.tex
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/authors.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/botan.rc
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/bugs.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/deprecated.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/fips140.pdf
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/fips140.tex
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/license.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/log.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/pgpkeys.asc
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/readme.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/rngs.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/thanks.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/todo.txt
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/tutorial.pdf
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/tutorial.tex
@dirrm include/botan
-@dirrm %%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%