aboutsummaryrefslogtreecommitdiff
path: root/security/botan
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-08-26 10:07:01 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-08-26 10:07:01 +0000
commit248851deaccbdb51236c6c53846ce375326354a9 (patch)
tree2e5be9a74391d1d5ba2017e47483e3eb3961821b /security/botan
parent7ceb0b1769d3140a47590bf6db7dba696c34ff01 (diff)
downloadports-248851deaccbdb51236c6c53846ce375326354a9.tar.gz
ports-248851deaccbdb51236c6c53846ce375326354a9.zip
Notes
Diffstat (limited to 'security/botan')
-rw-r--r--security/botan/Makefile19
-rw-r--r--security/botan/distinfo4
-rw-r--r--security/botan/files/patch-configure.pl24
-rw-r--r--security/botan/files/patch-modules::tm_posix.cpp11
-rw-r--r--security/botan/pkg-plist33
5 files changed, 60 insertions, 31 deletions
diff --git a/security/botan/Makefile b/security/botan/Makefile
index 403df507aba2..5a5afb462ad9 100644
--- a/security/botan/Makefile
+++ b/security/botan/Makefile
@@ -7,18 +7,16 @@
#
PORTNAME= botan
-PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTVERSION= 1.4.0
+PORTREVISION= 0
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= opencl
+MASTER_SITES= http://botan.randombit.net/files/
DISTNAME= Botan-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= clsung@FreeBSD.org
COMMENT= A portable, easy to use, and efficient C++ crypto library
-USE_REINPLACE= yes
USE_PERL5= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.pl
@@ -32,13 +30,16 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 500035
+CONFIGURE_ARGS+= --noauto
+PLIST_SUB+= OS_4="@comment "
+.else
+PLIST_SUB+= OS_4=""
+.endif
+
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS= ${BUILD_DEPENDS}
.endif
-post-patch:
- @${REINPLACE_CMD} -e "s,/usr/local,${PREFIX},g ; \
- s,%%CFLAGS%%,${CFLAGS},g" ${WRKSRC}/${CONFIGURE_SCRIPT}
-
.include <bsd.port.post.mk>
diff --git a/security/botan/distinfo b/security/botan/distinfo
index 3d57bf037b23..37065bba8b85 100644
--- a/security/botan/distinfo
+++ b/security/botan/distinfo
@@ -1,2 +1,2 @@
-MD5 (Botan-1.2.8.tgz) = dc84a09cad3e354bc21427b2baf3bb24
-SIZE (Botan-1.2.8.tgz) = 1249358
+MD5 (Botan-1.4.0.tgz) = 3154cdeecd2f65fa221cd9b5848b1fb2
+SIZE (Botan-1.4.0.tgz) = 1403507
diff --git a/security/botan/files/patch-configure.pl b/security/botan/files/patch-configure.pl
index 56db6f11ba49..749998bfcd28 100644
--- a/security/botan/files/patch-configure.pl
+++ b/security/botan/files/patch-configure.pl
@@ -1,11 +1,15 @@
---- configure.pl.orig Fri May 10 10:03:25 2002
-+++ configure.pl Fri May 10 10:03:35 2002
-@@ -1705,7 +1705,7 @@
- DOCDIR = \$(INSTALLROOT)/$doc_dir/OpenCL-\$(VERSION)
-
- OWNER = root
--GROUP = root
-+GROUP = wheel
- DATA_MODE = 644
- EXEC_MODE = 755
+--- configure.pl.orig Sat Jun 26 14:32:52 2004
++++ configure.pl Fri Jul 16 16:53:50 2004
+@@ -2007,7 +2007,11 @@
+ my $link_to = "-lm";
+ foreach my $lib (@{ $lib_list })
+ {
+- $link_to .= " -l" . $lib;
++ if ($lib =~ m/pthread/) {
++ $link_to .= " -" . $lib;
++ } else {
++ $link_to .= " -l" . $lib;
++ }
+ }
+ ##################################################
diff --git a/security/botan/files/patch-modules::tm_posix.cpp b/security/botan/files/patch-modules::tm_posix.cpp
new file mode 100644
index 000000000000..4d39bdedc9e9
--- /dev/null
+++ b/security/botan/files/patch-modules::tm_posix.cpp
@@ -0,0 +1,11 @@
+--- modules/tm_posix/tm_posix.cpp.orig Sat Jun 26 14:32:53 2004
++++ modules/tm_posix/tm_posix.cpp Fri Jul 16 16:32:28 2004
+@@ -6,7 +6,7 @@
+ #define _POSIX_C_SOURCE 199309
+ #include <botan/tm_posix.h>
+ #include <botan/util.h>
+-#include <time.h>
++#include <sys/time.h>
+
+ #ifndef CLOCK_REALTIME
+ #define CLOCK_REALTIME 0
diff --git a/security/botan/pkg-plist b/security/botan/pkg-plist
index 4702af918ac7..ea1c1b846137 100644
--- a/security/botan/pkg-plist
+++ b/security/botan/pkg-plist
@@ -28,7 +28,6 @@ include/botan/config.h
include/botan/crc24.h
include/botan/crc32.h
include/botan/crl_ent.h
-include/botan/cscipher.h
include/botan/ctr.h
include/botan/cts.h
include/botan/data_snk.h
@@ -44,14 +43,21 @@ include/botan/dsa.h
include/botan/eax.h
include/botan/ecb.h
include/botan/elgamal.h
-include/botan/emac.h
include/botan/eme.h
include/botan/emsa.h
+include/botan/eng_def.h
+include/botan/engine.h
include/botan/enums.h
+%%OS_4%%include/botan/es_egd.h
include/botan/es_file.h
+%%OS_4%%include/botan/es_ftw.h
+%%OS_4%%include/botan/es_unix.h
include/botan/exceptn.h
+%%OS_4%%include/botan/fd_unix.h
include/botan/filter.h
include/botan/filters.h
+include/botan/fips140.h
+include/botan/fips_rng.h
include/botan/gost.h
include/botan/has160.h
include/botan/haval.h
@@ -71,24 +77,25 @@ include/botan/lubyrack.h
include/botan/md2.h
include/botan/md4.h
include/botan/md5.h
-include/botan/md5mac.h
include/botan/mdx_hash.h
include/botan/mem_ops.h
include/botan/mgf1.h
include/botan/misty1.h
+%%OS_4%%include/botan/mmap_mem.h
include/botan/mod_exp.h
include/botan/mode_pad.h
include/botan/modebase.h
include/botan/mp_core.h
-include/botan/mp_impl.h
-include/botan/mp_mul.h
+include/botan/mp_madd.h
include/botan/mp_types.h
include/botan/mutex.h
+%%OS_4%%include/botan/mux_pthr.h
include/botan/nr.h
include/botan/numthry.h
include/botan/ofb.h
include/botan/oids.h
include/botan/omac.h
+include/botan/openpgp.h
include/botan/par_hash.h
include/botan/pbe.h
include/botan/pbe_pkcs.h
@@ -96,8 +103,10 @@ include/botan/pem.h
include/botan/pgp_s2k.h
include/botan/pipe.h
include/botan/pk_algs.h
+include/botan/pk_core.h
include/botan/pk_filts.h
include/botan/pk_keys.h
+include/botan/pk_ops.h
include/botan/pk_util.h
include/botan/pkcs10.h
include/botan/pkcs5.h
@@ -123,17 +132,19 @@ include/botan/serpent.h
include/botan/sha160.h
include/botan/sha256.h
include/botan/sha_64.h
-include/botan/shark.h
include/botan/skipjack.h
include/botan/square.h
include/botan/ssl3_mac.h
include/botan/symkey.h
include/botan/tea.h
-include/botan/threeway.h
include/botan/tiger.h
include/botan/timers.h
+%%OS_4%%include/botan/tm_posix.h
+%%OS_4%%include/botan/tm_unix.h
include/botan/twofish.h
include/botan/types.h
+include/botan/ui.h
+%%OS_4%%include/botan/unix_cmd.h
include/botan/util.h
include/botan/version.h
include/botan/whrlpool.h
@@ -148,17 +159,19 @@ include/botan/x509stor.h
include/botan/x917_rng.h
include/botan/x919_mac.h
include/botan/xtea.h
-lib/libbotan-1.2.8.so
-lib/libbotan-1.2.so
+lib/libbotan-1.4.0.so
+lib/libbotan-1.4.so
lib/libbotan-1.so
lib/libbotan.a
lib/libbotan.so
%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/api.pdf
%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/api.tex
-%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/botan.rc
%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/authors.txt
+%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/botan.rc
%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/bugs.txt
%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/deprecated.txt
+%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/fips140.pdf
+%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/fips140.tex
%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/license.txt
%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/log.txt
%%PORTDOCS%%share/doc/Botan-%%PORTVERSION%%/pgpkeys.asc