aboutsummaryrefslogtreecommitdiff
path: root/security/bro
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-09-19 02:09:40 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-09-19 02:09:40 +0000
commit5a33db37d4554b54e5b36c934e78555a90144658 (patch)
treecc7853651a4bb4ea71cc6665b05a3ed0ee79156f /security/bro
parent7274852ff66f53751941713c6f1d7ac31a45b1bf (diff)
downloadports-5a33db37d4554b54e5b36c934e78555a90144658.tar.gz
ports-5a33db37d4554b54e5b36c934e78555a90144658.zip
Notes
Diffstat (limited to 'security/bro')
-rw-r--r--security/bro/Makefile16
-rw-r--r--security/bro/files/patch-Conn.h20
2 files changed, 27 insertions, 9 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
index 5e592f40e74d..889d92229ff5 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -20,26 +20,24 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-pub-${PORTVERSION}a37
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-MAKE_ENV+= CC="${CC}" CFLAGS="${CFLAGS}"
+MAKE_ENV+= CC="${CC}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --libdir=${PREFIX}/share
USE_BISON= yes
USE_PERL5= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
post-extract:
- @(cd ${WRKSRC} && ${TAR} xfvz libedit.src.tar.gz > /dev/null)
+ @cd ${WRKSRC} && ${TAR} xfz libedit.src.tar.gz
post-patch:
@${REINPLACE_CMD} -e 's|CFLAGS+=-g -O0||g; \
s|CC=gcc||' \
${WRKSRC}/libedit/Makefile.in \
${WRKSRC}/libedit/Makefile
+ @${REINPLACE_CMD} -e "s,tr '\[a-z\]' '\[A-Z\]',tr 'a-z' 'A-Z',g" \
+ ${WRKSRC}/libedit/makelist
+ @${REINPLACE_CMD} -E -e 's,(const char\*) const (helpstring),\1 \2,g' \
+ ${WRKSRC}/DebugCmds.h
pre-configure:
@${ECHO_CMD} "Configure libedit..."
@@ -61,4 +59,4 @@ post-install:
@${GZIP_CMD} ${DOCSDIR}/bro-CN99.ps
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/bro/files/patch-Conn.h b/security/bro/files/patch-Conn.h
new file mode 100644
index 000000000000..89c2a233e68b
--- /dev/null
+++ b/security/bro/files/patch-Conn.h
@@ -0,0 +1,20 @@
+--- Conn.h.orig Sat Sep 18 15:42:16 2004
++++ Conn.h Sat Sep 18 15:42:30 2004
+@@ -223,6 +223,8 @@
+ return 1;
+ }
+
++ void DeleteTimer(double t);
++
+ protected:
+ virtual void UpdateEndpointVal(RecordVal* endp, int is_orig) = 0;
+
+@@ -235,8 +237,6 @@
+
+ friend class ConnectionTimer;
+ void RemoveTimer(Timer* t);
+-
+- void DeleteTimer(double t);
+
+ void InactivityTimer(double t);
+