aboutsummaryrefslogtreecommitdiff
path: root/security/broccoli
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2013-10-16 20:21:52 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2013-10-16 20:21:52 +0000
commit5f7f28bf7784a10f7e147c68e0e0ed9ed780fd9e (patch)
tree32632d28cf058c2c1c3f4960989c6c184377655b /security/broccoli
parentd478065e52acc252abf8c30dbbcd0400b8aa6a10 (diff)
downloadports-5f7f28bf7784a10f7e147c68e0e0ed9ed780fd9e.tar.gz
ports-5f7f28bf7784a10f7e147c68e0e0ed9ed780fd9e.zip
Notes
Diffstat (limited to 'security/broccoli')
-rw-r--r--security/broccoli/Makefile68
-rw-r--r--security/broccoli/distinfo2
-rw-r--r--security/broccoli/files/patch-aux-broccoli-CMakeLists.txt20
-rw-r--r--security/broccoli/pkg-descr4
-rw-r--r--security/broccoli/pkg-plist18
5 files changed, 112 insertions, 0 deletions
diff --git a/security/broccoli/Makefile b/security/broccoli/Makefile
new file mode 100644
index 000000000000..914076da743b
--- /dev/null
+++ b/security/broccoli/Makefile
@@ -0,0 +1,68 @@
+# Created by: Craig Leres <leres@ee.lbl.gov>
+# $FreeBSD$
+
+PORTNAME= broccoli
+PORTVERSION= 2.1
+CATEGORIES= security
+MASTER_SITES= http://www.bro-ids.org/downloads/release/
+DISTNAME= bro-${PORTVERSION}
+
+MAINTAINER= leres@ee.lbl.gov
+COMMENT= The Bro Client Communications Library
+
+BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
+ swig:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= GeoIP:${PORTSDIR}/net/GeoIP
+
+EXTRACT_AFTER_ARGS= ${DISTNAME}/aux/broccoli
+
+USES= cmake:outsource perl5
+USE_LDCONFIG= yes
+NO_MTREE= yes
+CMAKE_SOURCE_PATH= ${WRKSRC}/aux/broccoli
+
+.if defined(BRO_PREFIX)
+PREFIX=${BRO_PREFIX}
+PLIST_SUB+= CLEANUP_PREFIX=""
+.else
+PLIST_SUB+= CLEANUP_PREFIX="@comment "
+.endif
+CMAKE_ARGS+= -D CMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
+ -D PY_MOD_INSTALL_DIR:PATH=${PREFIX}
+
+OPTIONS_DEFINE= DEBUG PYTHON RUBY
+
+DEBUG_DESC= Compile in debugging mode
+PYTHON_DESC= Build python bindings for broccoli
+RUBY_DESC= Build ruby bindings for broccoli
+
+NO_STAGE= yes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDEBUG}
+CMAKE_ARGS+= -D ENABLE_DEBUG:BOOL=true
+.endif
+
+.if ${PORT_OPTIONS:MPYTHON}
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON=""
+.else
+CMAKE_ARGS+= -D DISABLE_PYTHON_BINDINGS:BOOL=true
+PLIST_SUB+= PYTHON="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MRUBY}
+USE_RUBY= yes
+PLIST_SUB+= RUBY=""
+.else
+CMAKE_ARGS+= -D DISABLE_RUBY_BINDINGS:BOOL=true
+PLIST_SUB+= RUBY="@comment "
+.endif
+
+post-install:
+ @${MKDIR} ${PREFIX}/etc
+ @${INSTALL_SCRIPT} ${WRKSRC}/aux/broccoli/broccoli.conf ${PREFIX}/etc/broccoli.conf.sample
+ @[ -f ${PREFIX}/etc/broccoli.conf ] || \
+ ${CP} -p ${PREFIX}/etc/broccoli.conf.sample ${PREFIX}/etc/broccoli.conf
+
+.include <bsd.port.mk>
diff --git a/security/broccoli/distinfo b/security/broccoli/distinfo
new file mode 100644
index 000000000000..603120096066
--- /dev/null
+++ b/security/broccoli/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bro-2.1.tar.gz) = 0d83b7c78d6e247d44b0407649df7fefa6da5c73a572a16c0096c9b7f2a955e0
+SIZE (bro-2.1.tar.gz) = 5627966
diff --git a/security/broccoli/files/patch-aux-broccoli-CMakeLists.txt b/security/broccoli/files/patch-aux-broccoli-CMakeLists.txt
new file mode 100644
index 000000000000..25308bf09936
--- /dev/null
+++ b/security/broccoli/files/patch-aux-broccoli-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- aux/broccoli/CMakeLists.txt.orig 2013-03-04 18:49:06.000000000 -0800
++++ aux/broccoli/CMakeLists.txt 2013-03-04 18:50:16.000000000 -0800
+@@ -96,12 +96,12 @@
+ ########################################################################
+ ## Install Files
+
+-include(InstallPackageConfigFile)
++#include(InstallPackageConfigFile)
+
+-InstallPackageConfigFile(
+- ${CMAKE_CURRENT_SOURCE_DIR}/broccoli.conf
+- ${BRO_SYSCONF_DIR}
+- broccoli.conf)
++#InstallPackageConfigFile(
++# ${CMAKE_CURRENT_SOURCE_DIR}/broccoli.conf
++# ${BRO_SYSCONF_DIR}
++# broccoli.conf)
+
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/broccoli-config DESTINATION bin)
+
diff --git a/security/broccoli/pkg-descr b/security/broccoli/pkg-descr
new file mode 100644
index 000000000000..694ad4cfd337
--- /dev/null
+++ b/security/broccoli/pkg-descr
@@ -0,0 +1,4 @@
+Broccoli is the Bro client communications library and lets you
+create applications that can speak the Bro communication protocol.
+
+WWW: http://www.icir.org/christian/broccoli/
diff --git a/security/broccoli/pkg-plist b/security/broccoli/pkg-plist
new file mode 100644
index 000000000000..768053aa8d48
--- /dev/null
+++ b/security/broccoli/pkg-plist
@@ -0,0 +1,18 @@
+bin/broccoli-config
+@exec mkdir -p %B
+@unexec cmp -s %D/etc/broccoli.conf.sample %D/etc/broccoli.conf && rm %D/etc/broccoli.conf || true
+etc/broccoli.conf.sample
+@exec test -f %B/broccoli.conf || cp -p %D/%F %B/broccoli.conf
+include/broccoli.h
+lib/libbroccoli.a
+lib/libbroccoli.so
+lib/libbroccoli.so.5
+lib/libbroccoli.so.5.1.0
+%%PYTHON%%lib/python/_broccoli_intern.so
+%%PYTHON%%lib/python/broccoli.py
+%%RUBY%%lib/ruby/broccoli_ext.so
+%%CLEANUP_PREFIX%%@dirrmtry lib
+%%CLEANUP_PREFIX%%@dirrmtry include
+%%CLEANUP_PREFIX%%@dirrmtry etc
+%%CLEANUP_PREFIX%%@dirrmtry bin
+%%CLEANUP_PREFIX%%@dirrmtry %D