aboutsummaryrefslogtreecommitdiff
path: root/security/bruteblock/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-08-23 10:47:15 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-08-23 10:47:15 +0000
commit3802aec8511a31bfa80988f7e576dfd847b8edd0 (patch)
treedf8bec3b05837d04f0e99af4f0f2490517f1d1df /security/bruteblock/Makefile
parent39fdff0a64ae24415adab6b59d58024af0866e58 (diff)
downloadports-3802aec8511a31bfa80988f7e576dfd847b8edd0.tar.gz
ports-3802aec8511a31bfa80988f7e576dfd847b8edd0.zip
Notes
Diffstat (limited to 'security/bruteblock/Makefile')
-rw-r--r--security/bruteblock/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/security/bruteblock/Makefile b/security/bruteblock/Makefile
index 4caa2634e74f..3a31f33dfd9d 100644
--- a/security/bruteblock/Makefile
+++ b/security/bruteblock/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bruteblock
-PORTVERSION= 0.0.4
+PORTVERSION= 0.0.5
CATEGORIES= security
MASTER_SITES= http://samm.kiev.ua/bruteblock/
@@ -23,6 +23,8 @@ MAN8= bruteblock.8
CONFDIR= ${PREFIX}/etc/${PORTNAME}
+PORTDOCS= FAQ README CHANGES
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 503000
@@ -33,13 +35,19 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bruteblock ${PREFIX}/sbin/
${INSTALL_PROGRAM} ${WRKSRC}/bruteblockd ${PREFIX}/sbin/
${MKDIR} ${PREFIX}/etc/bruteblock
-.for file in ssh # more configs are planned to be added
+.for file in ssh proftpd
${INSTALL_DATA} ${WRKSRC}/etc/${file}.conf ${CONFDIR}/${file}.conf.dist
if [ ! -f ${CONFDIR}/${file}.conf ]; then \
${INSTALL_DATA} ${CONFDIR}/${file}.conf.dist ${CONFDIR}/${file}.conf; \
fi
.endfor
${INSTALL_MAN} ${WRKSRC}/doc/bruteblock.8 ${PREFIX}/man/man8/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/FAQ ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/doc/README ${DOCSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/doc/CHANGES ${DOCSDIR}/
+.endif
post-install:
.if !defined(BATCH)