aboutsummaryrefslogtreecommitdiff
path: root/security/bruteblock
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-15 20:27:29 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-10-15 20:27:29 +0000
commit3e2b7a507f2e409fe27cf15af87c64f1a55e7569 (patch)
tree1a6baba472a606cccb594c2f53a5dae4200379ae /security/bruteblock
parent66c97ce6bc395357c9fa7a3ac3eb2fd95ffb1b9d (diff)
downloadports-3e2b7a507f2e409fe27cf15af87c64f1a55e7569.tar.gz
ports-3e2b7a507f2e409fe27cf15af87c64f1a55e7569.zip
Notes
Diffstat (limited to 'security/bruteblock')
-rw-r--r--security/bruteblock/Makefile2
-rw-r--r--security/bruteblock/files/patch-bruteblock.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/bruteblock/Makefile b/security/bruteblock/Makefile
index 2d92cc432c49..30107887eb62 100644
--- a/security/bruteblock/Makefile
+++ b/security/bruteblock/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bruteblock
PORTVERSION= 0.0.5
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= http://samm.kiev.ua/bruteblock/ \
http://mirror.amdmi3.ru/distfiles/
diff --git a/security/bruteblock/files/patch-bruteblock.c b/security/bruteblock/files/patch-bruteblock.c
new file mode 100644
index 000000000000..ddb5cfa4a7c3
--- /dev/null
+++ b/security/bruteblock/files/patch-bruteblock.c
@@ -0,0 +1,11 @@
+--- bruteblock.c.orig 2006-08-20 08:22:37.000000000 +0200
++++ bruteblock.c 2014-10-15 16:19:19.000000000 +0200
+@@ -99,7 +99,7 @@
+ snprintf(table, sizeof(table), "%d", ipfw2_table_no);
+ argv[1] = table;
+ argv[2] = command;
+- snprintf(utime, sizeof(utime), "%d",
++ snprintf(utime, sizeof(utime), "%lld",
+ time(NULL) + reset_ip);
+ argv[4] = utime;
+ argv[3] = host;