aboutsummaryrefslogtreecommitdiff
path: root/security/bugs
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-09-22 09:12:31 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-09-22 09:12:31 +0000
commit7f6c37b99b7fe1eff6b9d055ba6446848b057876 (patch)
treec2a238ef82b3dfe817eb5dd3746011bda2ba5031 /security/bugs
parent58c11ef9cb7d8e826486057632128300f0513ea3 (diff)
downloadports-7f6c37b99b7fe1eff6b9d055ba6446848b057876.tar.gz
ports-7f6c37b99b7fe1eff6b9d055ba6446848b057876.zip
Notes
Diffstat (limited to 'security/bugs')
-rw-r--r--security/bugs/Makefile46
-rw-r--r--security/bugs/files/patch-aa11
-rw-r--r--security/bugs/pkg-descr16
3 files changed, 37 insertions, 36 deletions
diff --git a/security/bugs/Makefile b/security/bugs/Makefile
index fd6f073c2303..64b5b334b9f8 100644
--- a/security/bugs/Makefile
+++ b/security/bugs/Makefile
@@ -1,4 +1,4 @@
-# Created by: Stephane Legrand
+# Created by: Stephane Legrand <stephane@lituus.fr>
# $FreeBSD$
PORTNAME= bugs
@@ -9,42 +9,56 @@ MASTER_SITES= SUNSITE/apps/crypto
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= Great cryptography library and sample programs
+COMMENT= Great cryptographic library and sample programs
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+NO_STAGE= yes
USES= gmake
-
-MAKE_JOBS_UNSAFE= yes
+MAKE_ARGS= CC="${CC}" BFLAG="${CFLAGS}" \
+ INSTALL_PATH="${PREFIX}/${DISTNAME}"
PLIST_SUB= PORTVERSION="${PORTVERSION}"
DOCSDIR= ${PREFIX}/${DISTNAME}/doc
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+post-patch:
+# Sanitize permissions so "make clean" can work
+ @${CHMOD} +x ${WRKSRC}/lib/unix ${WRKSRC}/lib/windows
+# Allow parallel builds (-jX): fix make(1) syntax, register dependencies
+ @${REINPLACE_CMD} -E 's+cd (.*); make+$$(MAKE) -C \1+' \
+ ${WRKSRC}/Makefile.bsd
+ @${ECHO_CMD} 'apps: lib' >> ${WRKSRC}/Makefile.bsd
+ @${REINPLACE_CMD} -E '/^(bcrypt|bchat|bpass|blogin|bkey|bpassdel|bmore|block|bunlock|shell):/s+ *$$+ extra.o+' \
+ ${WRKSRC}/apps/Makefile.bsd
+
post-configure:
- (cd ${WRKSRC}; ${MAKE} bsd);
- ${REINPLACE_CMD} -e 's:^INSTALL_PATH = "/usr/local/bugs-.*":INSTALL_PATH = "${PREFIX}/${DISTNAME}":' ${WRKSRC}/Makefile;
- ${REINPLACE_CMD} -e 's/^install: instchoice all/install: instchoice/' ${WRKSRC}/Makefile;
- # Comment the docs installation
- ${REINPLACE_CMD} -e 's+\(@echo "Copying docs.*\)+# \1+' ${WRKSRC}/Makefile;
- ${REINPLACE_CMD} -e 's+\(@cp -rf ./doc/.*\)+# \1+' ${WRKSRC}/Makefile;
+ ${MAKE_CMD} -C ${WRKSRC} bsd
+ @${REINPLACE_CMD} -e 's/^install: instchoice all/install: instchoice/' ${WRKSRC}/Makefile;
+ @${REINPLACE_CMD} -e 's+\(@echo "Copying docs.*\)+# \1+' ${WRKSRC}/Makefile;
+ @${REINPLACE_CMD} -e 's+\(@cp -rf ./doc/.*\)+# \1+' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's+\(@cp -rf ./doc/.*\)+# \1+' ${WRKSRC}/Makefile
post-build:
@${LN} -sf ${WRKSRC}/lib/unix/*.a ${WRKSRC}/lib/
-pre-install:
- (cd ${WRKSRC}; ${MAKE} test)
-
post-install:
@${MKDIR} ${PREFIX}/${DISTNAME}/include
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/${DISTNAME}/include
.for file in bchat bcrypt bhide bkey block blogin bmore bpass bpassdel bunlock
@${STRIP_CMD} ${PREFIX}/${DISTNAME}/${file}
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
.endif
+test: build
+ ${MAKE_CMD} -C ${WRKSRC} test
+
+regression-test: test
+
.include <bsd.port.mk>
diff --git a/security/bugs/files/patch-aa b/security/bugs/files/patch-aa
deleted file mode 100644
index a3acd844d86f..000000000000
--- a/security/bugs/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/unix/Makefile.bsd.orig Thu Jun 6 17:17:21 2002
-+++ lib/unix/Makefile.bsd Thu Jun 6 17:32:09 2002
-@@ -1,6 +1,6 @@
- #YOU MUST CHOOSE YOUR COMPILER
--#CC=gcc
--#BFLAG=-Wall -O3
-+CC?=cc
-+BFLAG= ${CFLAGS}
-
- all: message bugscrypt.a
-
diff --git a/security/bugs/pkg-descr b/security/bugs/pkg-descr
index aefda394fa00..b991056e1f83 100644
--- a/security/bugs/pkg-descr
+++ b/security/bugs/pkg-descr
@@ -1,13 +1,11 @@
-This package include a C library and some samples program that
-demonstrate that this library is powerful.
+This package include a C library and some sample programs that demonstrate
+the library's power.
-It is a cryptography library, you can crypt any type of data.
-Your key length to crypt is unlimited.
-You can generate password, manage users, hide text in file, etc.
-
-
-ATTENTION !!! IN SOME COUNTRIES THIS SOFTWARE MAY BE ILLEGAL SO DON'T USE
-IT IF YOU ARE NOT ALLOWED...
+It is a cryptographic library: you can crypt any type of data. Key length
+is unlimited. You can generate password, manage users, hide text in file,
+etc.
+ATTENTION!!! IN SOME COUNTRIES THIS SOFTWARE MAY BE ILLEGAL, SO DON'T USE
+IT IF YOU ARE NOT ALLOWED.
WWW: http://www.encryptsolutions.com/