aboutsummaryrefslogtreecommitdiff
path: root/security/ca_root_nss/Makefile
diff options
context:
space:
mode:
authorFlorian Smeets <flo@FreeBSD.org>2013-10-24 20:10:51 +0000
committerFlorian Smeets <flo@FreeBSD.org>2013-10-24 20:10:51 +0000
commitc8acac8ff4da7a9058be1bd158e66ce777005fa0 (patch)
tree00e7591130dd8fd16b4d50214b63721e7d93f322 /security/ca_root_nss/Makefile
parentbd675ff4114b03547b104816304be009f5627a6d (diff)
downloadports-c8acac8ff4da7a9058be1bd158e66ce777005fa0.tar.gz
ports-c8acac8ff4da7a9058be1bd158e66ce777005fa0.zip
Notes
Diffstat (limited to 'security/ca_root_nss/Makefile')
-rw-r--r--security/ca_root_nss/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/security/ca_root_nss/Makefile b/security/ca_root_nss/Makefile
index bb7d487f6a39..db4667ad0ba8 100644
--- a/security/ca_root_nss/Makefile
+++ b/security/ca_root_nss/Makefile
@@ -2,7 +2,6 @@
PORTNAME= ca_root_nss
PORTVERSION= ${VERSION_NSS}
-PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= MOZILLA/security/nss/releases/${DISTNAME:U:C/[-.]/_/g}_RTM/src
DISTNAME= nss-${VERSION_NSS}${NSS_SUFFIX}
@@ -25,14 +24,13 @@ PLIST_SUB+= CERTDIR=${CERTDIR}
# !!! Please DO NOT submit patches for new version until it has !!!
# !!! been committed there first. !!!
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
-VERSION_NSS= 3.15.1
+VERSION_NSS= 3.15.2
#NSS_SUFFIX= .with.ckbi.1.93
CERTDATA_TXT_PATH= nss-${VERSION_NSS}/nss/lib/ckfw/builtins/certdata.txt
BUNDLE_PROCESSOR= MAca-bundle.pl
SUB_FILES= MAca-bundle.pl
SUB_LIST= VERSION_NSS=${VERSION_NSS}
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:METCSYMLINK}
@@ -55,10 +53,10 @@ do-build: apply-slist
${WRKDIR}/ca-root-nss.crt
do-install:
- ${MKDIR} ${PREFIX}/${CERTDIR}
- ${INSTALL_DATA} ${WRKDIR}/ca-root-nss.crt ${PREFIX}/${CERTDIR}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${CERTDIR}
+ ${INSTALL_DATA} ${WRKDIR}/ca-root-nss.crt ${STAGEDIR}${PREFIX}/${CERTDIR}
.if ${PORT_OPTIONS:METCSYMLINK}
- ${LN} -sf ${PREFIX}/${CERTDIR}/ca-root-nss.crt /etc/ssl/cert.pem
+ ${LN} -sf ${STAGEDIR}${PREFIX}/${CERTDIR}/ca-root-nss.crt /etc/ssl/cert.pem
.endif
.include <bsd.port.mk>