aboutsummaryrefslogtreecommitdiff
path: root/security/ccrypt/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-20 06:44:33 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-20 06:44:33 +0000
commit04fbd578b9fea5feca9faa0a06561186f1c81496 (patch)
tree4005da22015d20ff400b125422094174d621cd6e /security/ccrypt/Makefile
parentfd774fa7f8aa394e399ede35f3953fb4093a9f0e (diff)
downloadports-04fbd578b9fea5feca9faa0a06561186f1c81496.tar.gz
ports-04fbd578b9fea5feca9faa0a06561186f1c81496.zip
Notes
Diffstat (limited to 'security/ccrypt/Makefile')
-rw-r--r--security/ccrypt/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/security/ccrypt/Makefile b/security/ccrypt/Makefile
index 13f8ee21ed1a..bde19236f42e 100644
--- a/security/ccrypt/Makefile
+++ b/security/ccrypt/Makefile
@@ -8,6 +8,7 @@
PORTNAME= ccrypt
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://quasar.mathstat.uottawa.ca/~selinger/ccrypt/download/
@@ -15,11 +16,11 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
MAN1= ccrypt.1
@@ -28,6 +29,12 @@ MLINKS= ccrypt.1 ccencrypt.1 \
ccrypt.1 ccat.1
post-patch:
- @${REINPLACE_CMD} -e "s,gtar,tar,g" ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|gtar|tar|g' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ ${DOCSDIR}
+.endif
.include <bsd.port.mk>