aboutsummaryrefslogtreecommitdiff
path: root/security/ccrypt
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-09 12:54:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-09 12:54:01 +0000
commit23ef68143118a593b02e87059eb5f22d6914d45e (patch)
treed87076f8442269fc7e49f8c61b1243fb9de77ed4 /security/ccrypt
parentc9c2a887d740a565dd5887ae3e2a8280bf5a5822 (diff)
downloadports-23ef68143118a593b02e87059eb5f22d6914d45e.tar.gz
ports-23ef68143118a593b02e87059eb5f22d6914d45e.zip
Notes
Diffstat (limited to 'security/ccrypt')
-rw-r--r--security/ccrypt/Makefile10
-rw-r--r--security/ccrypt/distinfo6
-rw-r--r--security/ccrypt/files/patch-Makefile.in11
-rw-r--r--security/ccrypt/files/patch-src-main.c13
-rw-r--r--security/ccrypt/files/patch-src-platform.h12
-rw-r--r--security/ccrypt/pkg-plist1
6 files changed, 8 insertions, 45 deletions
diff --git a/security/ccrypt/Makefile b/security/ccrypt/Makefile
index 532723d88878..613e35aa7b03 100644
--- a/security/ccrypt/Makefile
+++ b/security/ccrypt/Makefile
@@ -3,23 +3,23 @@
# Date created: Feb 7, 2002
# Whom: ijliao
#
+
# $FreeBSD$
#
PORTNAME= ccrypt
-PORTVERSION= 1.8
+PORTVERSION= 1.9
CATEGORIES= security
MASTER_SITES= SF \
- http://www.mathstat.dal.ca/~selinger/ccrypt/download/
-
+ http://www.mathstat.dal.ca/~selinger/ccrypt/download/
MAINTAINER= corky1951@comcast.net
COMMENT= A command-line utility for encrypting and decrypting files and streams
.if !defined(WITHOUT_NLS)
-USE_GNOME= intltool
+USE_GNOME= intltool
USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+PLIST_SUB+= NLS=""
.else
USE_PERL5_BUILD= yes
CONFIGURE_ARGS+= --disable-nls
diff --git a/security/ccrypt/distinfo b/security/ccrypt/distinfo
index c674afccbb8e..c922d8c5f1d6 100644
--- a/security/ccrypt/distinfo
+++ b/security/ccrypt/distinfo
@@ -1,3 +1,3 @@
-MD5 (ccrypt-1.8.tar.gz) = c8be3f35b8dddf3310ca043cd9817620
-SHA256 (ccrypt-1.8.tar.gz) = efd0487ebd21b7aee5c0d6c205d638c29880f3c4163d4bdfa9477c7838f61677
-SIZE (ccrypt-1.8.tar.gz) = 665596
+MD5 (ccrypt-1.9.tar.gz) = c3f78019d7a166dd66f1d4b1390c62c2
+SHA256 (ccrypt-1.9.tar.gz) = 6538cb75f7f45faf20f912c7b0d284831b0afced9fc61984b8d45a990276ebaf
+SIZE (ccrypt-1.9.tar.gz) = 667059
diff --git a/security/ccrypt/files/patch-Makefile.in b/security/ccrypt/files/patch-Makefile.in
deleted file mode 100644
index 6c1fa446bb1e..000000000000
--- a/security/ccrypt/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2009-06-05 07:59:43.000000000 -0700
-+++ Makefile.in 2009-06-10 18:06:23.000000000 -0700
-@@ -251,7 +251,7 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
--SUBDIRS = m4 po intl src emacs doc check
-+SUBDIRS = m4 po intl src doc check
- EXTRA_DIST = m4/ChangeLog config.rpath README-WIN intltool-extract.in \
- intltool-merge.in intltool-update.in
-
diff --git a/security/ccrypt/files/patch-src-main.c b/security/ccrypt/files/patch-src-main.c
deleted file mode 100644
index 0241affcb291..000000000000
--- a/security/ccrypt/files/patch-src-main.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/main.c.orig 2009-06-05 07:58:59.000000000 -0700
-+++ src/main.c 2009-06-10 16:56:56.000000000 -0700
-@@ -519,10 +519,6 @@
- }
- }
-
-- /* reset stdin/stdout to binary mode under Windows */
-- setmode(0,O_BINARY);
-- setmode(1,O_BINARY);
--
- /* if --keyref given, check encryption keys against named file */
- if (cmd.keyref && (cmd.mode == ENCRYPT || cmd.mode == KEYCHANGE)) {
- f = fopen(cmd.keyref, "rb");
diff --git a/security/ccrypt/files/patch-src-platform.h b/security/ccrypt/files/patch-src-platform.h
deleted file mode 100644
index 157bd95022d7..000000000000
--- a/security/ccrypt/files/patch-src-platform.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/platform.h.orig 2009-06-05 07:39:49.000000000 -0700
-+++ src/platform.h 2009-06-10 17:18:40.000000000 -0700
-@@ -78,9 +78,6 @@
-
- #else /* on a POSIX system, map these to no-ops */
-
--static inline void setmode(int fd, int mode) {
-- return;
--}
- #ifndef O_BINARY
- #define O_BINARY 0
- #endif /* O_BINARY */
diff --git a/security/ccrypt/pkg-plist b/security/ccrypt/pkg-plist
index 9774d42fa083..b89038ef82da 100644
--- a/security/ccrypt/pkg-plist
+++ b/security/ccrypt/pkg-plist
@@ -8,4 +8,3 @@ bin/ccrypt
%%PORTDOCS%%share/doc/ccrypt/ccrypt.html
%%PORTDOCS%%share/doc/ccrypt/cypfaq01.txt
%%PORTDOCS%%@dirrm share/doc/ccrypt
-