aboutsummaryrefslogtreecommitdiff
path: root/security/cfv
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-11-02 13:23:08 +0000
committerChris Rees <crees@FreeBSD.org>2012-11-02 13:23:08 +0000
commite6cecb1d3837f20455af42dc76acaedf2cbcc6ef (patch)
treeeeaefb1bdf4f8e1e933d3d8aa0f93e0771f82c9b /security/cfv
parentaff1d05882522e90316a1a5b89b95fe49630b7c9 (diff)
downloadports-e6cecb1d3837f20455af42dc76acaedf2cbcc6ef.tar.gz
ports-e6cecb1d3837f20455af42dc76acaedf2cbcc6ef.zip
Notes
Diffstat (limited to 'security/cfv')
-rw-r--r--security/cfv/Makefile32
-rw-r--r--security/cfv/distinfo2
-rw-r--r--security/cfv/files/extra-psyco-patch-Makefile11
-rw-r--r--security/cfv/files/patch-Makefile9
-rw-r--r--security/cfv/pkg-descr15
-rw-r--r--security/cfv/pkg-plist4
6 files changed, 73 insertions, 0 deletions
diff --git a/security/cfv/Makefile b/security/cfv/Makefile
new file mode 100644
index 000000000000..684b0657b993
--- /dev/null
+++ b/security/cfv/Makefile
@@ -0,0 +1,32 @@
+# Created by: Ying-Chieh Liao <ijliao@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cfv
+PORTVERSION= 1.18.3
+CATEGORIES= security
+MASTER_SITES= SF
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Utility to both test and create .sfv, .csv, and md5sum files
+
+USE_PYTHON= yes
+ALL_TARGET= cfv.wrapper
+INSTALL_TARGET= install-wrapper
+
+MAN1= cfv.1
+
+OPTIONS_DEFINE_i386= PSYCO
+PSYCO_DESC= Enable devel/py-psyco optimization support
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/Makefile
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MPSYCO}
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
+
+EXTRA_PATCHES+= ${FILESDIR}/extra-psyco-patch-Makefile
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/cfv/distinfo b/security/cfv/distinfo
new file mode 100644
index 000000000000..efc8e7a00caa
--- /dev/null
+++ b/security/cfv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cfv-1.18.3.tar.gz) = ff28a8aa679932b83eb3b248ed2557c6da5860d5f8456ffe24686253a354cff6
+SIZE (cfv-1.18.3.tar.gz) = 68030
diff --git a/security/cfv/files/extra-psyco-patch-Makefile b/security/cfv/files/extra-psyco-patch-Makefile
new file mode 100644
index 000000000000..373ea63294bc
--- /dev/null
+++ b/security/cfv/files/extra-psyco-patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2009-03-05 21:47:26.000000000 -0300
++++ Makefile 2009-03-05 21:51:11.000000000 -0300
+@@ -37,7 +37,7 @@
+ #this will create a wrapper script that calls python directly (if we can find it), or using the bin/env trick.
+ #we don't need to check for PYTHON being set to something, since os.path.join handles the case of the component being an absolute path
+ cfv.wrapper:
+- $(PYTHON) -c 'import string,os; py=filter(lambda x: os.path.isfile(x),map(lambda x: os.path.join(x,"$(PYTHON)"),string.split(os.environ["PATH"],":"))); py.append(" /usr/bin/env $(PYTHON)"); open("cfv.wrapper","w").write("#!%s\nimport cfv\ncfv.main()\n"%py[0])'
++ $(PYTHON) -c 'import string,os; py=filter(lambda x: os.path.isfile(x),map(lambda x: os.path.join(x,"$(PYTHON)"),string.split(os.environ["PATH"],":"))); py.append(" /usr/bin/env $(PYTHON)"); open("cfv.wrapper","w").write("#!%s\ntry:\n import psyco\n import re\n psyco.cannotcompile(re.compile)\n psyco.profile()\nexcept ImportError:\n pass\nimport cfv\ncfv.main()\n"%py[0])'
+
+ $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(bindir):
+ $(install_dir) $@
diff --git a/security/cfv/files/patch-Makefile b/security/cfv/files/patch-Makefile
new file mode 100644
index 000000000000..6b1134bb4948
--- /dev/null
+++ b/security/cfv/files/patch-Makefile
@@ -0,0 +1,9 @@
+--- Makefile.orig Fri Dec 7 17:01:19 2001
++++ Makefile Fri Dec 7 17:01:56 2001
+@@ -1,5 +1,5 @@
+ PYTHON=python
+-prefix=/usr/local
++prefix=%%PREFIX%%
+ exec_prefix=${prefix}
+
+ #finds the site-packages dir that matches the selected prefix, or if none do, falls back to wherever it can find one..
diff --git a/security/cfv/pkg-descr b/security/cfv/pkg-descr
new file mode 100644
index 000000000000..6fa67034f29c
--- /dev/null
+++ b/security/cfv/pkg-descr
@@ -0,0 +1,15 @@
+cfv is a utility to both test and create .sfv, .csv and md5sum files. These
+files are commonly used to ensure the correct retrieval or storage of data.
+
+Features:
+ - supports .sfv, .csv(2, 3, and 4 field variants), md5sum, bsd md5
+ sha1sum, .torrent and (test-only) .par, .par2 file formats
+ - automatic checksum file naming ability in create mode
+ - recursive operation
+ - show unverified files option
+ - ignore case and fix path separator options for cross platform use
+ - transparent gzip support for checksum files
+ - configurable renaming of bad files (with testing against previous bad
+ files, to save only unique differing copies)
+
+WWW: http://cfv.sourceforge.net/
diff --git a/security/cfv/pkg-plist b/security/cfv/pkg-plist
new file mode 100644
index 000000000000..3ebd478de2dd
--- /dev/null
+++ b/security/cfv/pkg-plist
@@ -0,0 +1,4 @@
+bin/cfv
+%%PYTHON_SITELIBDIR%%/cfv.py
+%%PYTHON_SITELIBDIR%%/cfv.pyc
+%%PYTHON_SITELIBDIR%%/cfv.pyo