aboutsummaryrefslogtreecommitdiff
path: root/security/checkpassword
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2013-10-23 22:32:40 +0000
committerRenato Botelho <garga@FreeBSD.org>2013-10-23 22:32:40 +0000
commit30d69281ccaa0340967ada61e6659cec241a49e1 (patch)
tree6388c1eaee4596082284c22dac9d97f9e114c7d0 /security/checkpassword
parent79a4b63aee6fceafa0626bf927fe700cfc3a9031 (diff)
downloadports-30d69281ccaa0340967ada61e6659cec241a49e1.tar.gz
ports-30d69281ccaa0340967ada61e6659cec241a49e1.zip
Notes
Diffstat (limited to 'security/checkpassword')
-rw-r--r--security/checkpassword/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/security/checkpassword/Makefile b/security/checkpassword/Makefile
index d09db121edcb..1f8b535ca756 100644
--- a/security/checkpassword/Makefile
+++ b/security/checkpassword/Makefile
@@ -16,11 +16,9 @@ OPTIONS_DEFINE= DOCS
ALL_TARGET= it
INSTALL_TARGET= setup
-
PLIST_FILES= bin/checkpassword
PORTDOCS= CHANGES FILES README SYSDEPS TARGETS TODO VERSION
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
@@ -29,13 +27,13 @@ post-patch:
do-configure:
@${ECHO_CMD} '${CC} ${CFLAGS} -s -lcrypt' > ${WRKSRC}/conf-cc
@${ECHO_CMD} '${CC} ${CFLAGS} -s -lcrypt' > ${WRKSRC}/conf-ld
- @${ECHO_CMD} ${PREFIX} >${WRKSRC}/conf-home
+ @${ECHO_CMD} ${STAGEDIR}${PREFIX} >${WRKSRC}/conf-home
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif