aboutsummaryrefslogtreecommitdiff
path: root/security/chkrootkit/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2003-04-09 08:22:12 +0000
committerKevin Lo <kevlo@FreeBSD.org>2003-04-09 08:22:12 +0000
commit2c2587e36733025da7c9bd01ab4ed356e919be67 (patch)
tree7156e7bcc715a08a01c9e7f91f6931aa0d3250fd /security/chkrootkit/Makefile
parentf812bb7fe2931bf883b29e3ab0eb689499fd7388 (diff)
downloadports-2c2587e36733025da7c9bd01ab4ed356e919be67.tar.gz
ports-2c2587e36733025da7c9bd01ab4ed356e919be67.zip
Notes
Diffstat (limited to 'security/chkrootkit/Makefile')
-rw-r--r--security/chkrootkit/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/security/chkrootkit/Makefile b/security/chkrootkit/Makefile
index 481bb8cd6848..0fb41ad7fbac 100644
--- a/security/chkrootkit/Makefile
+++ b/security/chkrootkit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= chkrootkit
-PORTVERSION= 0.39a
+PORTVERSION= 0.40
CATEGORIES= security
MASTER_SITES= ftp://ftp.pangeia.com.br/pub/seg/pac/
@@ -15,7 +15,7 @@ COMMENT= A tool to locally check for signs of a rootkit
USE_REINPLACE= yes
-ALL_TARGET= chkrootkit chklastlog chkwtmp chkproc chkdirs ifpromisc
+ALL_TARGET= chkrootkit chklastlog chkwtmp chkproc chkdirs ifpromisc check_wtmpx strings
DOCFILES= COPYRIGHT README README.chklastlog README.chkwtmp
@@ -28,6 +28,8 @@ pre-patch:
s#\./chkwtmp#${PREFIX}/sbin/chkwtmp#g; \
s#\./chkproc#${PREFIX}/sbin/chkproc#g; \
s#\./chkdirs#${PREFIX}/sbin/chkdirs#g; \
+ s#\./check_wtmpx#${PREFIX}/sbin/check_wtmpx#g; \
+ s#\./strings#${PREFIX}/sbin/strings#g; \
s#\./ifpromisc#${PREFIX}/sbin/ifpromisc#g;' \
${WRKSRC}/chkrootkit
@@ -38,6 +40,8 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/chkproc ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/chkdirs ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/ifpromisc ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/check_wtmpx ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/strings ${PREFIX}/sbin
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/chkrootkit
${INSTALL_DATA} ${DOCFILES:C,^,${WRKSRC}/,} ${PREFIX}/share/doc/chkrootkit