aboutsummaryrefslogtreecommitdiff
path: root/security/chntpw
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-10 06:53:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-10-10 06:53:56 +0000
commit86a41ad12db8d5385128d62de66943bc09bb0b82 (patch)
treecc92287a9ee6b18fae509e87f695d164f02a5462 /security/chntpw
parenteb85a988f12cad136bb8a5ba81a04dfbe2d819e4 (diff)
downloadports-86a41ad12db8d5385128d62de66943bc09bb0b82.tar.gz
ports-86a41ad12db8d5385128d62de66943bc09bb0b82.zip
Notes
Diffstat (limited to 'security/chntpw')
-rw-r--r--security/chntpw/Makefile29
1 files changed, 19 insertions, 10 deletions
diff --git a/security/chntpw/Makefile b/security/chntpw/Makefile
index 813a2e660dd5..05f0d311b05e 100644
--- a/security/chntpw/Makefile
+++ b/security/chntpw/Makefile
@@ -10,27 +10,36 @@ DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= buganini@gmail.com
COMMENT= Utility to set the password and edit registry on Microsoft NT system
+LICENSE= GPLv2
+
+OPTIONS_DEFINE= DOCS
+
USE_ZIP= yes
-USE_GMAKE= yes
USE_OPENSSL= yes
+USES= gmake
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
PLIST_FILES= bin/chntpw
PORTDOCS= README.txt WinReg.txt regedit.txt
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-NO_STAGE= yes
+.include <bsd.port.pre.mk>
+
post-patch:
- @${REINPLACE_CMD} -e '10 s,/usr,$$\(OPENSSLBASE\),' \
- ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CC=/d; /^OSSLPATH=/ s|=.*|=${OPENSSLBASE}|' ${WRKSRC}/Makefile
+.if ${ARCH} == "amd64"
+ @${REINPLACE_CMD} -e '/^CFLAGS=/ s| -m32||' ${WRKSRC}/Makefile
+.endif
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/chntpw ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${INSTALL_PROGRAM} ${WRKSRC}/chntpw ${STAGEDIR}${PREFIX}/bin
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>