aboutsummaryrefslogtreecommitdiff
path: root/security/chroot_safe
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 20:47:45 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 20:47:45 +0000
commit459b8d16e6677705b10cda8abbd664e03de3a00c (patch)
tree28bf58514fd27af0aa8f2d27b7ebf0bfd316ed0e /security/chroot_safe
parent1abc97d3d906267fd9a7141cc46f909d38aa1800 (diff)
downloadports-459b8d16e6677705b10cda8abbd664e03de3a00c.tar.gz
ports-459b8d16e6677705b10cda8abbd664e03de3a00c.zip
Notes
Diffstat (limited to 'security/chroot_safe')
-rw-r--r--security/chroot_safe/Makefile29
-rw-r--r--security/chroot_safe/distinfo3
-rw-r--r--security/chroot_safe/pkg-descr5
3 files changed, 37 insertions, 0 deletions
diff --git a/security/chroot_safe/Makefile b/security/chroot_safe/Makefile
new file mode 100644
index 000000000000..30c48c1b61b9
--- /dev/null
+++ b/security/chroot_safe/Makefile
@@ -0,0 +1,29 @@
+# Ports collection Makefile for: chroot_safe
+# Date created: 11 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= chroot_safe
+PORTVERSION= 1.4
+CATEGORIES= security sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= chrootsafe
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= A tool to chroot softwares easily
+
+GNU_CONFIGURE=YES
+USE_REINPLACE=YES
+
+MAN1= chroot_safe.1
+PLIST_FILES= sbin/chroot_safe libexec/chroot_safe/chroot_safe.so
+PLIST_DIRS= libexec/chroot_safe
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|CXX=g++|CXX?=c++|' \
+ -e 's|-o chroot_safe.so|chroot_safe.cpp -o chroot_safe.so|' \
+ ${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} 's|chroot(1)|chroot(8)|' ${WRKSRC}/chroot_safe.1.in
+
+.include <bsd.port.mk>
diff --git a/security/chroot_safe/distinfo b/security/chroot_safe/distinfo
new file mode 100644
index 000000000000..763797528375
--- /dev/null
+++ b/security/chroot_safe/distinfo
@@ -0,0 +1,3 @@
+MD5 (chroot_safe-1.4.tgz) = 4a1150626746e15e157e092840f595ed
+SHA256 (chroot_safe-1.4.tgz) = dcdd299e0275838531bbc53de3bb5ecd70f99d0af5fa328e8de761b4de4623bf
+SIZE (chroot_safe-1.4.tgz) = 25886
diff --git a/security/chroot_safe/pkg-descr b/security/chroot_safe/pkg-descr
new file mode 100644
index 000000000000..04a91ccb39c5
--- /dev/null
+++ b/security/chroot_safe/pkg-descr
@@ -0,0 +1,5 @@
+ chroot_safe, a tool to chroot any application in a sane manner without
+requring binaries, shared libraries etc within the chroot or any support from
+the application. Works with any dynamically linked application.
+
+WWW: http://sourceforge.net/projects/chrootsafe/