aboutsummaryrefslogtreecommitdiff
path: root/security/cisco-torch/Makefile
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-03-14 21:56:05 +0000
committerMark Felder <feld@FreeBSD.org>2016-03-14 21:56:05 +0000
commit436b8d6d582260b3afee3db2ea05ac05ef847e0d (patch)
tree7cc643d4f8f35826583f93db18c63ab45fe8b735 /security/cisco-torch/Makefile
parent4fc98b4698978280c6e6b2a66a1c788075ec210b (diff)
downloadports-436b8d6d582260b3afee3db2ea05ac05ef847e0d.tar.gz
ports-436b8d6d582260b3afee3db2ea05ac05ef847e0d.zip
Notes
Diffstat (limited to 'security/cisco-torch/Makefile')
-rw-r--r--security/cisco-torch/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/security/cisco-torch/Makefile b/security/cisco-torch/Makefile
new file mode 100644
index 000000000000..0b6d7687f384
--- /dev/null
+++ b/security/cisco-torch/Makefile
@@ -0,0 +1,47 @@
+# Created by: Rihaz Jerrin <rihaz.jerrin@gmail.com>
+# $FreeBSD$
+
+PORTNAME= cisco-torch
+PORTVERSION= 0.4
+DISTVERSIONSUFFIX= b
+CATEGORIES= security
+MASTER_SITES= http://www.hackingciscoexposed.com/tools/
+
+MAINTAINER= rihaz.jerrin@gmail.com
+COMMENT= Mass Cisco Vulnerability Scanner
+
+LICENSE= LGPL21
+
+RUN_DEPENDS= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet \
+ p5-Net-SSH2>=0:${PORTSDIR}/net/p5-Net-SSH2 \
+ p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay
+
+USES= perl5 shebangfix
+SHEBANG_FILES= ${WRKSRC}/cisco-torch.pl
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PORTDOCS= README.txt TODO CHANGELOG.txt LICENSE
+FILELIST= brutefile.txt \
+ community.txt \
+ fingerprint.db \
+ password.txt \
+ tfingerprint.db \
+ users.txt
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/cisco-torch.pl ${STAGEDIR}${PREFIX}/bin/cisco-torch
+ ${MKDIR} ${STAGEDIR}${DATADIR}/include
+ ${MKDIR} ${STAGEDIR}${DATADIR}/tftproot
+ ${MKDIR} ${STAGEDIR}${ETCDIR}
+.for i in ${FILELIST}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DATADIR}
+.endfor
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${DATADIR})
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/torch.conf ${STAGEDIR}${ETCDIR}/torch.conf.sample
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>