aboutsummaryrefslogtreecommitdiff
path: root/security/cksfv
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-23 12:35:04 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-23 12:35:04 +0000
commit466ee71916f880e5a070350d8a84407ee75fe12d (patch)
tree021b5abe00057205a871723ca245d4d88618447f /security/cksfv
parent40b020793032c5b947e54b0822101c7cb3160cb0 (diff)
downloadports-466ee71916f880e5a070350d8a84407ee75fe12d.tar.gz
ports-466ee71916f880e5a070350d8a84407ee75fe12d.zip
Notes
Diffstat (limited to 'security/cksfv')
-rw-r--r--security/cksfv/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/security/cksfv/Makefile b/security/cksfv/Makefile
index 3998bcc2bf31..4ce821c0851a 100644
--- a/security/cksfv/Makefile
+++ b/security/cksfv/Makefile
@@ -15,26 +15,24 @@ LICENSE= GPLv2
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --mandir=${PREFIX}/man --prefix=${PREFIX}
-MAN1= cksfv.1
-PLIST_FILES= bin/cksfv
+PLIST_FILES= bin/cksfv man/man1/cksfv.1.gz
PORTDOCS= README ChangeLog
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's|^\(CC\)=|\1?=|' ${WRKSRC}/src/Makefile.in
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif