aboutsummaryrefslogtreecommitdiff
path: root/security/clamav/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-02-17 22:57:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-02-17 22:57:32 +0000
commit61f47b838cd2b333605555641a324f04b42c0426 (patch)
tree25373ecf52a0dcfa52ebceca5d66130d3dd23582 /security/clamav/Makefile
parentf1446d79aba8ff068ef78ec072e78d37e1e39ddb (diff)
downloadports-61f47b838cd2b333605555641a324f04b42c0426.tar.gz
ports-61f47b838cd2b333605555641a324f04b42c0426.zip
Notes
Diffstat (limited to 'security/clamav/Makefile')
-rw-r--r--security/clamav/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 3b9261871e5e..a5f35cbb9c49 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,7 +7,6 @@
PORTNAME= clamav
PORTVERSION= ${DISTVERSION:C/([a-z])[a-z]*/.\1/g:S/-/./g}
-PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= clamav
@@ -24,7 +23,7 @@ RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
arc:${PORTSDIR}/archivers/arc \
unzip:${PORTSDIR}/archivers/unzip
-DISTVERSION= 0.82
+DISTVERSION= 0.83
OPTIONS= MILTER "Compile the milter interface" Off \
CURL "Support URL downloading" Off
@@ -58,13 +57,6 @@ CPPFLAGS+= -I${LOCALBASE}/include \
LDFLAGS+= -L${LOCALBASE}/lib \
${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
-
-.if !defined(WITHOUT_LDAP) && exists(${LOCALBASE}/lib/libldap.so)
-USE_OPENLDAP= yes
-LDFLAGS+= -lldap
-.endif
-
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
MAN1= clamscan.1 freshclam.1 sigtool.1 clamdscan.1
@@ -110,7 +102,13 @@ SED_SCRIPT+= -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
PLIST_SUB+= RC_DIR=${RC_DIR} \
RC_SUFX=${RC_SUFX}
+.include <bsd.port.pre.mk>
+
.if defined(WITH_MILTER)
+.if !defined(WITHOUT_LDAP) && exists(${LOCALBASE}/lib/libldap.so)
+USE_OPENLDAP= yes
+LDFLAGS+= -lldap
+.endif
.if !exists(/usr/lib/libmilter.a)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
CONFIGURE_ENV+= SENDMAIL="${LOCALBASE}/sbin/sendmail"