aboutsummaryrefslogtreecommitdiff
path: root/security/clamav/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-01-27 16:56:35 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-01-27 16:56:35 +0000
commitc1a3055b5f90c05c7c9507f85fba7a2db8cbab89 (patch)
treec45694b7eb52d6ffa26dd1c837f3b611feaa48c8 /security/clamav/Makefile
parentb774d8516d36e42280cfcdf357e743ab78c12fd5 (diff)
Execute a "make check" at post-build target, add libcheck as a dependency for it
Notes
Notes: svn path=/head/; revision=248701
Diffstat (limited to 'security/clamav/Makefile')
-rw-r--r--security/clamav/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 2eedf83eae5c..e42654611ac1 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= SF
MAINTAINER= garga@FreeBSD.org
COMMENT= Command line virus scanner written entirely in C
+BUILD_DEPENDS= ${LOCALBASE}/include/check.h:${PORTSDIR}/devel/libcheck
+
OPTIONS= ARC "Enable arch archives support" On \
ARJ "Enable arj archives support" On \
LHA "Enable lha archives support" On \
@@ -47,6 +49,7 @@ CONFIGURE_ARGS= --libdir=${PREFIX}/lib \
--enable-bigstack \
--enable-readdir_r \
--enable-gethostbyname_r \
+ --enable-check \
--disable-dependency-tracking
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
@@ -172,6 +175,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
${WRKSRC}/libclamunrar/unrar.c
+post-build:
+ @${MAKE} -C ${WRKSRC} check
+
pre-su-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL