aboutsummaryrefslogtreecommitdiff
path: root/security/clamav/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-06-09 23:55:20 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-06-09 23:55:20 +0000
commit102398f45af0dc85ff09b1df0ce02a40b3a96149 (patch)
treec5f95d2137bcf2b35d4128d34d427681be5e65f6 /security/clamav/Makefile
parente4e0822bc9a12623298512990409b21958cc1152 (diff)
Notes
Diffstat (limited to 'security/clamav/Makefile')
-rw-r--r--security/clamav/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 0af57b9282a7..f740f14150ff 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -54,6 +54,10 @@ CPPFLAGS+= -I${LOCALBASE}/include \
LDFLAGS+= -L${LOCALBASE}/lib \
${PTHREAD_LIBS}
+# This port has a problem with -pthread,
+# force to use -lthr until it's not fixed.
+PTHREAD_LIBS= -lthr
+
MAN1= clamconf.1 \
clamscan.1 \
freshclam.1 \
@@ -98,14 +102,6 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
.include <bsd.port.pre.mk>
-# This port has a problem with -pthread,
-# force to use -lthr until it's not fixed.
-.if ${OSVERSION} >= 601000
-PTHREAD_LIBS= -lthr
-.else
-PTHREAD_LIBS= -lpthread
-.endif
-
.if defined(WITH_ARC)
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
.endif