aboutsummaryrefslogtreecommitdiff
path: root/security/clamav/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-05-20 18:06:34 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-05-20 18:06:34 +0000
commitaf30d669792de46e1e1693ec6152eff952d90b20 (patch)
treefb63c96eacda6d46e0e4155c57f55e55a907899d /security/clamav/Makefile
parentc4c23065c477c9a94e35955157f2945f270d5197 (diff)
downloadports-af30d669792de46e1e1693ec6152eff952d90b20.tar.gz
ports-af30d669792de46e1e1693ec6152eff952d90b20.zip
Notes
Diffstat (limited to 'security/clamav/Makefile')
-rw-r--r--security/clamav/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 0174285ce6b0..cbfa2ac38212 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.93
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
@@ -68,7 +69,7 @@ CONFLICTS= clamav-devel-[0-9]*
CLAMAVUSER?= clamav
CLAMAVGROUP?= clamav
-CLAMAV_CLAMD_SOCKET?= ${RUNDIR}/clamd
+CLAMAV_CLAMD_SOCKET?= ${RUNDIR}/clamd.sock
CLAMAV_MILTER_SOCKET?= ${RUNDIR}/clmilter.sock
SUB_FILES= pkg-install pkg-deinstall
@@ -138,16 +139,18 @@ CONFIGURE_ARGS+=--without-iconv
.if defined(WITH_MILTER)
USE_RC_SUBR+= clamav-milter
-.if defined(WITH_LDAP) && exists(${LOCALBASE}/lib/libldap.so)
+. if defined(WITH_LDAP) && exists(${LOCALBASE}/lib/libldap.so)
USE_OPENLDAP= yes
LDFLAGS+= -lldap
-.endif
-.if !exists(/usr/lib/libmilter.a) || exists(${LOCALBASE}/lib/libmilter.a)
+. endif
+
+. if !exists(/usr/lib/libmilter.a) || exists(${LOCALBASE}/lib/libmilter.a)
BUILD_DEPENDS+= ${LOCALBASE}/lib/libmilter.a:${PORTSDIR}/mail/sendmail
CONFIGURE_ARGS+= --with-sendmail=${LOCALBASE}/sbin/sendmail
-.else
+. else
CONFIGURE_ARGS+= --with-sendmail=/usr/sbin/sendmail
-.endif
+. endif
+
CONFIGURE_ARGS+= --enable-milter
PLIST_SUB+= CLAMAV-MILTER=""
.else