aboutsummaryrefslogtreecommitdiff
path: root/security/clamav/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-04-13 17:49:09 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-04-13 17:49:09 +0000
commit661e726925234578da52d075c1e92bef2801be57 (patch)
treef598db86267045b9db4f834ce41720199a66926b /security/clamav/Makefile
parent6a0c248a84fe716f80bec7d732bb6ec2106ce9a3 (diff)
- Update to 0.90.2
- Add a patch to increase performance of clamd in threaded systems [1] - Change clamav-milter rc.d script to use a var to determine seconds of timeout to wait clamd socket be started [2] - Add support to gethostbyname_r() on FreeBSD 6 and above [3] - Install clamav-config.h [3] - Fix all dependencies for klamav work fine [3] PR: ports/111130 [2], ports/111478 [3] Submitted by: Anton Yuzhaninov <citrin@rambler-co.ru> [1] Denis Eremenko <moonshade@pnhz.kz> [2] Anderson S. Ferreira <anderson@cnpm.embrapa.br> [3] Obtained from: https://wwws.clamav.net/bugzilla/show_bug.cgi?id=434 [1]
Notes
Notes: svn path=/head/; revision=189917
Diffstat (limited to 'security/clamav/Makefile')
-rw-r--r--security/clamav/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 8324ae0f8895..56653a5af6f6 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= clamav
-PORTVERSION= 0.90.1
-PORTREVISION= 1
+PORTVERSION= 0.90.2
CATEGORIES= security
MASTER_SITES= SF
@@ -47,7 +46,6 @@ CONFIGURE_ARGS= --with-dbdir=${DBDIR} \
--disable-clamuko \
--disable-clamav \
--enable-bigstack \
- --disable-gethostbyname_r \
--enable-readdir_r \
--disable-dependency-tracking
CPPFLAGS+= -I${LOCALBASE}/include \
@@ -99,6 +97,12 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 600000
+CONFIGURE_ARGS+= --disable-gethostbyname_r
+.else
+CONFIGURE_ARGS+= --enable-gethostbyname_r
+.endif
+
# This port has a problem with -pthread,
# force to use -lthr until it's not fixed.
.if ${OSVERSION} >= 601000
@@ -159,6 +163,7 @@ pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
+ @${INSTALL_DATA} ${WRKSRC}/clamav-config.h ${PREFIX}/include
.for c in clamd freshclam
@[ -f ${PREFIX}/etc/${c}.conf ] || \
${CP} ${PREFIX}/etc/${c}.conf.default ${PREFIX}/etc/${c}.conf