aboutsummaryrefslogtreecommitdiff
path: root/security/clamav
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-09-27 16:59:07 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-09-27 16:59:07 +0000
commit0113e481921f8ce6410c25dc9feafceb014076fd (patch)
tree35e0bbc081c05252770158eb31e89e4b0df54bc7 /security/clamav
parent9654df7b64c8eb9a7f02d3acd07b2ec86cac58ab (diff)
downloadports-0113e481921f8ce6410c25dc9feafceb014076fd.tar.gz
ports-0113e481921f8ce6410c25dc9feafceb014076fd.zip
Notes
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index de26bd1d4a34..40b75fceaf91 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= clamav
-DISTVERSION= 0.96.3
+PORTVERSION= 0.96.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
@@ -19,17 +20,18 @@ OPTIONS= ARC "Enable arch archives support" On \
UNZOO "Enable zoo archives support" On \
UNRAR "Enable rar archives support" On \
LLVM "Enable JIT Bytecode compiler" On \
+ TESTS "Run compile-time tests (req. python)" On \
MILTER "Compile the milter interface" Off \
LDAP "libmilter was built with LDAP" Off \
ICONV "Enable ICONV support" Off \
STDERR "Print logs to stderr instead of stdout" Off \
EXPERIMENTAL "Build experimental code" Off
-GNU_CONFIGURE= yes
-MAKE_JOBS_SAFE= yes
-USE_LDCONFIG= yes
-USE_RC_SUBR= clamav-clamd clamav-freshclam
-CONF_FILES= clamd freshclam
+GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+USE_RC_SUBR= clamav-clamd clamav-freshclam
+CONF_FILES= clamd freshclam
LICENSE= GPLv2
@@ -140,9 +142,10 @@ CONFIGURE_ARGS+=--without-iconv
.if defined(WITH_LLVM) && ${ARCH} != "sparc64"
CONFIGURE_ARGS+=--enable-llvm
+USE_GMAKE= yes
+. if defined(WITH_TESTS)
USE_PYTHON_BUILD= yes
-USE_GMAKE= yes
-USE_GCC= 4.2+
+. endif
.else
CONFIGURE_ARGS+=--disable-llvm
.endif
@@ -201,7 +204,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
${WRKSRC}/libclamunrar/unrar.c
-.if defined(WITH_LLVM)
+.if defined(WITH_LLVM) && defined(WITH_TESTS)
pre-configure:
@if ! ${PYTHON_CMD} -c "import thread" >/dev/null 2>&1; then \
${ECHO_MSG} ""; \
@@ -214,7 +217,7 @@ pre-configure:
fi
.endif
-.if ${OSVERSION} >= 700000
+.if defined(WITH_TESTS) && ${OSVERSION} >= 700000
post-build:
@if [ -f "${PY_NO_THREAD}" ]; then \
${MAKE} -C ${WRKSRC} check; \